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CHƯƠNG 1: CÁC TÍNH NĂNG CƠ BẢN CỦA MAPINFO
1. Giới thiệu về phần mềm MapInfo 

Hiện nay trên thế giới đang phổ biến các phần mềm GIS như ARC/INFO, ARC-GIS, INTER-GRAPH, ARCVIEW, IDRISI, MAPINFO... Nhìn chung các phần mềm này đều có những chức năng tương tự nhau về việc xử lý và biên tập bản đồ khá tốt, tuy nhiên mỗi phần mềm của các hãng thì cũng có những chức năng ưu việt khác nhau. 

Phần mềm GIS-MapInfo được xem là sử dụng khá phổ biến ở Việt Nam, nó được xem như là một công cụ khá hữu hiệu để tạo ra và quản lý một cơ sở dữ liệu vừa và nhỏ trên máy tính cá nhân. Sử dụng công cụ MapInfo có thể thực hiện xây dựng một hệ thông tin địa lý, phục vụ cho mục đích nghiên cứu khoa học, sản xuất của các tổ chức kinh tế xã hội các ngành và địa phương. Ngoài ra, MapInfo là một phần mềm tương đối gọn nhẹ và dễ sử dụng. Đặc biệt, sử dụng cho mục đích giảng dạy về GIS rất có hiệu quả. MapInfo cũng còn là một phần mềm đang được ứng dụng phổ biến rất ở nhiều nước trên thế giới.

2. Tập tin dữ liệu của MapInfo 

 MapInfo là một phần mềm hệ thông tin địa lý GIS cho giải pháp máy tính để bàn (Desktop solution). Các thông tin trong MapInfo được tổ chức theo từng bảng hay còn gọi là lớp dữ liệu (Table), mỗi một Table là một tập hợp các File về thông tin đồ hoạ hoặc phi đồ hoạ chứa các bản ghi dữ liệu mà hệ thống tạo ra, các File này có tên giống nhau nhưng chỉ khác nhau ở phần mở rộng (Ext). Tùy theo tính chất của dữ liệu mà số file có thể thay đổi từ 2 đến 6 file. Chỉ có thể truy nhập vào các chức năng của phần mềm MapInfo khi ta đã mở ít nhất một Table. Cơ cấu tổ chức thông tin của các đối tượng địa lý được tổ chức theo các File sau đây. 

· tenfile.tab 
File liên kết các file trong một lớp. 

· tenfile.dat 
Chứa dữ liệu thuộc tính dạng bảng như excel. 

· tenfile.map     Chứa dữ liệu dạng không gian (đồ hoạ). 
· tenfile.id 
Chứa thông tin liên kết dữ liệu với các đối tượng với nhau. 

· tenfile.ind 
Chứa thông tin về chỉ mục (giúp cho việc tìm kiếm đối tượng đồ hoạ). 

· tenfile.wor      Tập tin quản lý các dữ liệu đang xử lý hay sản phẩm liên kết giữa các lớp hiện hành. 

 
MapInfo xem tenfile.tab là đại diện cho 5 tập tin đầu tiên vừa nêu trên. Có nghĩa khi chọn tập tin có phần mở rộng là .tab trong môi trường MapInfo là chọn một lớp (layer) dữ liệu của MapInfo. 

Nếu dữ liệu là ảnh ở dạng ma trận (raster), tenfile.bmp (hay phần mở rộng là gif, jpg...) sẽ kết hợp với tenfile.tab một khi được mở hay đăng nhập toạ độ địa lý. Ngoài các dữ liệu trên, MapInfo còn sử dụng được các dữ liệu đã được xây dựng trên các phần mềm khác như Foxpro (.dbf), Excel (.xls), Access (.mdb)... Trong đó các dữ liệu được xây dựng trên phần mềm Access được xem là lý tưởng nhất. 

3  Khởi động và cách mở lớp dữ liệu trong MapInfo 

-
Để khởi động Chương trình MapInfo -> nhấn 2 lần chuột (double click) vào biểu tượng MapInfo   [image: image2.jpg]


       trên màn hình sẽ xuất hiện cửa sổ như sau: 
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Mở một lớp dữ liệu:  Vào Menu -> Open Table trên Menu
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 (tương tự như chọn Open Table trong cửa sổ Quick Start ở hình 1) sẽ xuất hiện cửa sổ sau :
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-
Trong khung Preferred View, mặc định là Automatic, có nghĩa là: 

- 
Nếu lớp dữ liệu này không có chứa dữ liệu không gian, chỉ có các dữ liệu phi không gian còn gọi là dữ liệu thuộc tính, thì trên màn hình sẽ xuất hiện một cửa sổ dữ liệu dạng bảng với các hàng và cột (Browse window) của lớp dữ liệu đó như hình dưới. 
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-
Ta có thể chọn :

 
 Browse                   xem dữ liệu ở dạng bảng với các hàng và cột;

 
Current Mapper    mở lớp dữ liệu mới trong cùng một cửa sổ đang mở; 

 
New Mapper          mở lớp dữ liệu mới trong một cửa sổ mới; hay 

 
No View                 mở lớp dữ liệu mới nhưng được đưa vào bên trong bộ nhớ của máy tính, không xuất hiện gì trên màn hình. 
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-
Ta có thể mở nhiều lớp dữ liệu cùng một lúc và thông thường để xây dựng một bản đồ chúng ta phải sử dụng mở nhiều lớp dữ liệu. Ví dụ như: lớp ranh giới huyện, lớp đường,  lớp trung tâm huyện... như hình  dưới đây. 

4 Các thao tác trên cửa sổ bản đồ (Map Window)
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     Màn hình mapinfo ở chế độ thường sử dụng nhất
4.1 Thay đổi độ phóng đại và vùng nhìn thấy 
▪ 
Khi ta thay đổi độ phóng đại (zoom) thì tham số Zoom ở thanh trạng thái sẽ cho biết giá trị ngoài thực tế của chiều rộng cửa sổ bản đồ đang hoạt động (hình 5). Tắt hoặc mở thanh trạng thái này bằng Show/Hide Status Bar trong Options trên Menu chính.
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▪ 
Để thay đổi độ lớn của bản đồ trong cửa sổ bản đồ, chúng ta có thể sử dụng:
· Biểu tượng phóng lớn  [image: image6.jpg]


 hay thu nhỏ  [image: image7.jpg]



-    Vào Map -> Change View trên Menu chính hay nhấn vào biểu tượng [image: image8.jpg]


  , sẽ xuất hiện cửa sổ Change với các tham số sau: 
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Zoom (Window With): Cho biết giá trị ngoài thực tế của chiều rộng cửa sổ bản đồ đang hoạt động.
Map Scale: Cho biết giá trị hiện tại 1cm trên bản đồ (máy tính) tương ứng với giá trị bao nhiêu trên thực tế.

Center of Windows: Cho biết toạ độ của trung tâm cửa sổ bản đồ.
▪ 
Chúng ta có thể thay đổi các tham số trên và một khi có sự thay đổi, thì một hay nhiều các tham số có liên quan trên cũng thay đổi theo cho phù hợp.
▪ 
Thường thì sau khi mở một lớp dữ liệu, có thể trong cửa sổ bản đồ không chứa hết tất cả các đối tượng. Để thấy được tất cả các đối tượng trong cửa sổ này chúng ta vào Map -> View Entire Layer trên Menu lệnh rồi chọn lớp dữ liệu muốn xem trong cửa sổ View Entire Layer và nhấn OK.

▪ 
Chúng ta có thể trở lại tình trạng của cửa sổ bản đồ trước khi vừa thay đổi với Map -> Previous View trên Menu lệnh.
▪ 
Để có thêm cửa sổ bản đồ giống như cửa sổ đang làm việc, chúng ta vào Map 
->Clone View hoặc Edit -> Copy Map Window (Ctrl-C) rồi chọn Edit -> Paste Map Window (Crtl-V) trên Menu lệnh.

▪ 
Ngoài ra chúng ta cũng có thể di chuyển các đối tượng trong cửa sổ bản đồ với biểu tượng Select   [image: image10.jpg]


x trong hộp công cụ Main bằng cách nhấn chuột vào biểu tượng này, sau đó chuyển chuột đến đối tượng cần di chuyển rồi nhấn giữ chuột trái và rê chuột về hướng mà chúng ta muốn.
4.2 Cách chọn đối tượng địa lý trong cửa sổ bản đồ 
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▪ 
Chúng ta có thể chọn trực tiếp một đối tượng hiện diện trong khung nhìn cửa sổ bản đồ bằng cách nhấn chuột vào biểu tượng Select  [image: image11.jpg]


  hiện diện trong khung nhìn cửa sổ bản đồ trong hộp công cụ, sau đó di chuyển con trỏ vào trong cửa sổ bản đồ, đến vị trí đối tượng muốn chọn và nhấn chuột. Đối tượng được chọn sẽ hiện rõ lên. Để chọn nhiều đối tượng, chúng ta nhấn giữ phím Shift đồng thời nhấn chuột vào các đối tượng mà ta muốn chọn. Để chọn một đối tượng nằm ở lớp bên dưới tại một vị trí, chúng ta sử dụng phím Crtl. 
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▪ 
Trong cửa sổ dữ liệu chúng ta có thể chọn đối tượng theo yêu cầu của chúng ta, ví dụ muốn chọn đối tượng có tên là thành phố "thị xã kon tum", chúng ta sẽ chọn trong cửa sổ dữ liệu đối tượng này một cách dễ dàng. Khi chúng ta nhấn chuột vào ô trống ở đầu hàng của một đối tượng, chúng lập tức chuyển sang màu đen và như vậy chúng ta sẽ chọn tương ứng đối tượng đó trong cửa sổ bản đồ. Nhưng giả sử trong trường hợp bảng dữ liệu lớn và chúng ta khó có thể nhìn thấy trong cửa sổ bản đồ, sử dụng chức năng Query -> Find... sau đó nhập dữ kiện vào. Ví dụ như "thị xã kon tum" lập tức sẽ xuất hiện đối tượng này trong vùng nhìn trên màn hình với ký hiệu đánh dấu mà ta đã chọn trước đó trong cửa sổ Find -> Respecify như hình dưới.
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▪
Nhấn chuột vào biểu tượng Marquee Select  [image: image12.jpg]


 hay Radius Select [image: image13.jpg]


 trong hộpcông cụ để chọn tất cả các đối tượng trong hình chữ nhật hay hình tròn do chúng ta khoanh vùng trước đó.
▪ 
Biểu tượng Polygon Select  [image: image14.jpg]


  để chọn các đối tượng trong vùng cần chọn.

▪ 
Biểu tượng Boundary Select  [image: image15.jpg]


  trong hộp công cụ là để chọn tất cả các đối tượng bên trong ranh giới của một đối tượng kiểu vùng đã xác định trước.
▪ 
Để biết thông tin về một vị trí nào đó trong cửa sổ bản đồ, chúng ta sử dụng biểu tượng Info  [image: image16.jpg]


  trong hộp công cụ. Một khi đã chọn biểu tượng này và nhấn chuột vào một vị trí nào đó trong cửa sổ bản đồ thì màn hình sẽ xuất hiện cửa sổ Info Tool đồng thời trong tab Info Tool sẽ cho biết tại điểm vừa được chọn có bao nhiêu lớp dữ liệu. Nếu chúng ta nhấn chuột vào một trong các lớp dữ liệu này thì sẽ biết các thông tin chứa trong lớp dữ liệu đó (liệt kê giá trị các cột của lớp dữ liệu này của đối tượng tương ứng được chọn).
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 Ở đây chúng ta có thể sửa chữa hay nhập mới các giá trị này. Ở hình minh họa trên, đối tượng được chọn là vùng Thị xã Kon Tum với các số liệu tương ứng như: huyện là thị xã Kon Tum (Huyện), mã Huyện là 60.101 ( Ma_Huyen ), thuộc tỉnh Kon Tum       ( Tinh ), với diện tích là 917,1 ( Dien_tich ), và có số dân là 99.505 người ( Danso ).
5.
Các thao tác trên lớp dữ liệu
5.1 Thay đổi thuộc tính của một lớp dữ liệu trong MapInfo 
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5.2 Xem và sửa đổi các thuộc tính của đối tượng 
▪ 
Các đối tượng của một lớp dữ liệu chỉ có thể sửa đổi khi lớp dữ liệu này có thuộc tính thấy được và sửa đổi được. Tuy nhiên, chỉ có một lớp dữ liệu có thể sửa đổi được tại một thời điểm. 

▪
Để xem thông tin của một đối tượng, chúng ta chọn đối tượng đó rồi vào Edit -> Get Info hay nhấn phím F7, hoặc nhấn chuột 2 lần trên đối tượng muốn chọn xem thôngtin. Nếu đối tượng chọn thuộc lớp dữ liệu thấy được nhưng không sửa đổi được thì những thông tin xuất hiện trong cửa sổ Region (line, polyline, point) Object sẽ không cho phép ta hiệu chỉnh. Ngược lại nếu đối tượng được chọn thuộc lớp dữ liệu thấy được và có thể sửa đổi được thì chúng ta có thể thay đổi được một số thông số và thuộc tính thể hiện của đối tượng đó bằng cách nhấn chuột vào nút Style . Tùy theo kiểu đối tượng sẽ xuất hiện những lựa chọn thay đổi tương ứng.
▪
Để thay đổi thuộc tính thể hiện của các đối tượng và tùy theo loại đối tượng mà chúng ta vào chọn Options -> Line Style / Region Style / Symbol Style / Text Style trên Menu lệnh hay nhấn chuột vào các biểu tượng tương ứng sau đây  [image: image18.jpg]
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…( các biểu tượng này còn xuất hiện trong thanh công cụ Drawing )
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Thanh công cụ Drawing

▪ 
Để dịch chuyển đối tượng (thay đổi tất cả các vị trí địa lý), nhấn chuột trái vào đối tượng muốn dịch chuyển, ấn và giữ chuột trái cho đến khi con trỏ xuất hiện hình mũi tên 4 chiều, sau đó rê chuột để dịch chuyển đối tượng đến vị trí mong muốn.
▪ 
Để sửa đổi hình dạng của các đối tượng kiểu vùng hay kiểu đường (thay đổi một số vị trí) chúng ta sử dụng chức năng Edit -> Reshape hay nhấn chuột vào biểu tượng Reshape  [image: image23.jpg]


  trong thanh công cụ Drawing. Biểu tượng này chỉ hiệu ứng khi có một đối tượng được chọn. Các điểm trung gian (node) của đối tượng được chọn sẽ hiện lên và chúng ta có thể di chuyển hay xoá các điểm (node) này. Mặt khác chúng ta cũng có thể thêm các điểm này với biểu tượng Add Node  [image: image24.jpg]


 trong thanh công cụ này.
Ngoài ra, chúng ta cũng có thể sử dụng các chức năng thông thường như Cut, Paste trong mục Edit để cắt, dán các đối tượng trong một lớp dữ liệu hay giữa các lớp dữ liệu với nhau. 
5.3 Lớp dữ liệu tạm thời trong cửa sổ bản đồ

[image: image99.jpg]SekotRecodsfiom Table: [Thia <]

tht Satisy: [Danso < 50000
Assist,

Store Resulsin Table:  [Selection
Sott Resuts by Cohmri [ none =

¥ Browse Resuls ™ Find Resull In Curtent Map Windon

[0 ] coet | SovTorut| LosdTotte| |




[image: image100.jpg]Select Calumns:

from Tables:

whete Condiion

[Count) *Tong_DVHC". SuniDien_tich]"Tong_Dientich”

[ 2

(3]

Columns
Operators

Aagegates

i

[Faci 2]




5.4 Vùng làm việc (Workspace)
 ▪ 
MapInfo có khả năng lưu giữ môi trường làm việc hiện có, bao gồm các lớp dữ liệu, trật tự của những lớp dữ liệu đó, thứ tự của các cửa sổ đang mở, kích thước và vị trí của chúng trên màn hình, cũng như kiểu chữ, kiểu đường, kiểu biểu tượng, kiểu vùng... đã được dùng để thể hiện các đối tượng. Tất cả các layer được lưu trữ trong một tập tin có phần mở rộng là .wor, còn gọi là Workspace (môi trường làm việc vào một thời điểm). 
 ▪ 
Để tạo ra một Workspace, chúng ta vào File -> Save Workspace và đặt tên .wor tại thư mục (Folder) tương ứng. Mở lại tập tin Workspace vào File -> Open Workspace để trở lại môi trường này. 
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 Chú ý: Sự sửa chữa không đúng trong file .wor sẽ làm hỏng việc thể hiện lại môi trường làm việc mà chúng ta đã lưu giữ trước đó nhưng không làm hỏng dữ liệu gốc trong MapInfo. 
CHƯƠNG 2: XÂY DỰNG DỮ LIỆU KHÔNG GIAN
 1  Tạo dữ liệu mới trong MapInfo 

▪ 
Để tạo mới một lớp dữ liệu (Table) theo dạng chuẩn của MapInfo, chọn File -> New Table, cửa sổ New Table sẽ xuất hiện như sau:
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 ▪
Chọn Open New Mapper hay Add to Current Mapper khi muốn tạo các đối tượng đồ hoạ. Nếu chỉ muốn tạo ra một cơ sở dữ liệu thì chọn Open New Browser. Nhấn chuột vào nút Create, cửa sổ New Table Structure xuất hiện. Cách khai báo trong cửa sổ này như hình : 
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▪ 
Mục Projection: 
-
Nếu tạo dữ liệu ở một vùng địa lý mới, trước hết phải khai báo mục Projection. Projection (hệ quy chiếu) là phương trình toán học để chuyển các đối tượng địa lý trên mặt đất lên mặt phẳng bản đố giấy sao cho hạn chế nhất được sự biến dạng. Nhấn chuột vào mục Projection, sẽ xuất hiện cửa sổ Choose Projection như sau: 
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-
Trước hết chúng ta chọn mục Category, và ứng với mỗi Category, chúng ta sẽ có một Category Members tương ứng với Category đó. Đối với Việt Nam chúng ta đã có sẵn một Category "VN-2000 su dung noi bo" được bổ sung vào danh sách các Category trên, Category này được các nhà làm bản đồ Việt Nam xây dựng và thống nhất trên toàn lãnh thổ Việt Nam (còn gọi là hệ toạ độ VN2000). Các Category Members trong "VN-2000 su dung noi bo" là một số phép chiếu có thể áp dụng trên lãnh thổ Việt Nam cũng được xem là quy định của ngành Địa chính Việt Nam. 

▪
Trường hợp vùng dữ liệu đã có sẵn các bản đồ ở dạng số, chúng ta nên mở một trong các bản đồ hiện có và tạo mới một dữ liệu trong cửa sổ bản đồ đang hoạt động (Add to Current Mapper), như vậy chúng ta có thể thừa kế các tham số liên quan đến Projection của cửa sổ bản đồ đang hoạt động. 

▪
Dữ liệu được tạo trong MapInfo có dạng là một bảng (tabular) giống như bảng dữ liệu trong FoxPro hay Excel... Bao gồm các hàng và cột. Mỗi cột là một thuộc tính tương ứng của các hàng là các đối tượng. 

▪
Nhấn chuột vào Add Field để thêm cột mới. Nhập tên cột vào cửa sổ Name, chọn kiểu dữ liệu tương ứng với cột này ở cửa sổ Type, tùy theo tính chất của dữ liệu mà kiểu dữ liệu có thể là một trong các kiểu sau đây :
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         Cách tạo thêm trường (Add Filed) trong cấu trúc Table mới 
-
Kiểu ký tự (character): 

Tối đa là 254 ký tự.
-
Kiểu số nguyên (Integer): 
Lưu giữ các số nguyên (-2.100.000.000 đến +2.100.000.000). 

-
Kiểu số nguyên ngắn (small Integer): 
Lưu giữ các số nguyên (-32.767 đến +32.767). 

-
Kiểu số thập phân động (float): Lưu giữ các số thập phân dạng dấu chấm tự do.
-
Kiểu số thập phân (Decimal): Lưu giữ các số thập phân dấu chấm cố định, tối đa dài 19 số.

 -
Kiểu ngày tháng (Date): Theo dạng mm-dd-yyyy hay mm/dd/yy .
-
Kiểu luận lý (logical): Chỉ có 2 giá trị là T (true) hay F (false). 

▪
Khai báo xong kiểu dữ liệu cho mỗi cột với các kiểu phù hợp với mục đích sử dụng. Chúng ta có thể sử dụng Up và Down để sắp xếp lại trật tự các cột khi xuất hiện ở dạng bảng cũng như Remove Field để loại bỏ cột ra khỏi bảng dữ liệu. 
▪
Khi tạo một lớp dữ liệu không gian mới (số hoá), thường chỉ nên có 2 cột, đó là cột mã số và cột tên của đối tượng địa lý tương ứng. Mã số thường là các mức độ khác nhau của kiểu đối tượng tương ứng và thường dùng để quản lý các đối tượng một cách khoa học hơn. Các đối tượng địa lý có thể có cùng tên hay cùng mã số. Chúng ta có thể thêm hay bớt các cột khác sau này khi cần thiết (sẽ được trình bày trong phần sau). 

▪
Trường hợp tạo lớp dữ liệu mới để lưu giữ các giá trị thuộc tính, chúng ta có thể khai báo thêm các cột và kiểu dữ liệu tương ứng với số liệu đã có sẵn. 

▪
Nhấn chuột vào mục Create rồi đặt tên cho lớp dữ liệu này tại thư mục thích hợp. 

2
Nhập các giá trị thuộc tính 
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▪
Đề nhập các dữ liệu thuộc tính, sau khi đã tạo ra một lớp dữ liệu mới với đầy đủ các cột tương ứng, chúng ta vào Window -> New Browser Windows (hay nhấn F2) và chọn lớp dữ liệu thuộc tính. Một cửa sổ dữ liệu sẽ xuất hiện như hình dưới đây: 
▪
Sau đó vào Edit -> New Row (hay nhấn tổ hợp phím Ctrl-E) để thêm các hàng trống rồi nhập số liệu tương ứng vào các ô. Dữ liệu được nhập phải có cùng kiểu với các cột tương ứng mà chúng ta đã tạo ra trước đó, trường hợp nhập sai kiểu MapInfo sẽ thông báo lỗi kiểu dữ liệu.

3
Số hoá bản đồ 

3.1 Định nghĩa 
▪
Số hoá bản đồ là quá trình vẽ lại một bản đồ giấy trên máy vi tính nhằm tạo ra một bản vẽ dạng số (digital format) của bản đồ đó. 

▪
Số hoá bản đồ là cách nhập dữ liệu không gian, nó ghi nhận toạ độ địa lý của các đối tượng trên mặt đất, lưu trữ dưới dạng số để có thể xử lý được trên máy tính. 

▪
Có 2 phương pháp số hoá bản đồ: Số hoá với bàn số hoá (digitizer) và số hoá từ ảnh quét (scanner) của bản đồ giấy. 

3.2 Tiến trình số hoá trên ảnh quét 
3.2.1 Khai báo đăng nhập tạo độ của ảnh quét 

▪
Bản đồ được quét bằng máy Scanner tạo nên các tập tin ảnh với phần mở rộng là .tif, .jpg, .bmp... Tùy theo kích thước của bản đồ mà quét thành những tập tin ảnh với khổ A4, A3 hay A0... 
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▪
Nhấn chuột vào mục Units để khai báo về đơn vị bản đồ là độ (degrees) hay mét (meters) tùy theo hệ quy chiếu tương ứng và điều kiện của bản đồ tham khảo. 

▪
Kế tiếp là khai báo các điểm xác định vị trí địa lý của khu vực bản đồ được quét. Để xác định vị trí địa lý của khu vực bản đồ được quét thì chúng ta phải khai báo tối thiểu là 4 điểm. Tùy vào chất lượng của ảnh quét mà số điểm khống chế sẽ tăng lên và tốt nhất là bạn phải có ít nhất một điểm khống chế ở góc ảnh. Nhấn chuột vào mục New để tiến hành khai báo một điểm mới. 

▪
Sử dụng biểu tượng phóng to (+) hay thu nhỏ (-) và các thanh trượt để đưa một khu vực bản đồ vào vùng nhìn trên máy .
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▪
Nhập kinh độ của điểm đã chọn vào khung Map X và vĩ độ vào khung Map Y theo tọa độ hệ mét hay hệ độ mà chúng ta đã khai báo trước đó ở mục Units. Nhấn OK, trong vùng thông tin các điểm đăng nhập sẽ xuất hiện thêm một hàng các tham số điểm vừa được khai báo. 
▪
Khi chúng ta đã khai báo (ít nhất 4 điểm) nên chú ý đến thông tin trong cột Error. trị số trong cột này sẽ được tính toán tự động theo toạ độ của các điểm đã được khai báo. Dĩ nhiên các trị số này càng nhỏ thì bản đồ đăng nhập càng có độ chính xác càng cao tương hợp với vị trí địa lý thực và ngược lại.
▪
Chúng ta cũng có thể sửa chữa lại các thông số của các điểm vừa khai báo (hoặc xoá đi) bằng cách chọn điểm cần sửa chữa (hoặc xoá đi) rồi chọn mục Edit hay Remove. 

▪
Khi các trị số trong cột Error có thể chấp nhận được, nhấn OK để kết thúc việc đăng nhập toạ độ của vùng ảnh quét. MapInfo sẽ tạo ra một tập tin có tên giống như tên của tập tin ảnh nhưng khác phần mở rộng là .tab và hiện diện ảnh quét trên cửa sổ bản đồ máy tính. 

▪
Ta có thể điều chỉnh độ sáng và độ tương phản của ảnh trong Table -> Raster -> Adjust Image Style. 
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▪
Trong MapInfo có một khả năng khác để nhập và sửa đổi toạ độ các điểm định vị khichúng ta đã có một lớp dữ liệu bản đồ dạng số của vùng bản đồ ảnh muốn đăng nhập với một số vị trí địa lý đặc biệt như giao điểm của các sông, đường hay hệ thống lưới ô vuông...

-
Vào File -> Open Table, chọn lớp dữ liệu bản đồ đã có của vùng địa lý tương ứng.Mở tiếp tập tin bản đồ ảnh (dạng raster, nếu muốn nhập toạ độ của các điểm định vị)hay tập tin .tab của bản đồ ảnh này (dạng MapInfo, nếu muốn sửa đổi toạ độ các định vị). Sau đó, vào Table -> Raster -> Modify Image Registration, xuất hiện cửa sổ Image Registration -> chọn New để đăng nhập một điểm mới hay chọn hàng ghi thông tin của điểm muốn sửa toạ độ.

-
Vào Table -> Raster -> Select Control Point From Map, khi vào phạm vi cửa sổ bản đồ hoạt động, con trỏ có dạng chủ thập (+), di chuyển con trỏ đến vị trí tương ứng trên bản đồ trong cửa sổ bản đồ hoạt động và nhấn chuột, cửa sổ Edit Control Point xuất hiện với toạ độ mới do MapInfo tính toán từ lớp bản đồ đã có. Nhấn OK để chấp nhận thông số do MapInfo đưa vào. Tương cho các điểm còn lại và kết thúc quá trình đăng ký ảnh.
3.2.2 Số hoá 
▪
Dữ liệu số hoá được ghi vào một lớp dữ liệu mới. Nếu chưa có lớp dữ liệu tương ứng để số hoá thì phải khai báo một lớp dữ liệu mới. Mở chồng lên cửa sổ của tập tin ảnh đã được đăng nhập một table mới. Kiểm tra lớp này để biết rõ là đã được chọn (Selectable) và sửa đổi được (Editable) trong Map -> Layer Control. 

▪
Mặc dù MapInfo cho phép nhiều kiểu đối tượng trên cùng một lớp dữ liệu, nhưng để tiện quản lý thông tin một cách khoa học ta nên tổ chức thành các lớp dữ liệu (layer) riêng biệt cho từng chủ đề tương ứng với một kiểu dữ liệu nhất định. Ví dụ: Lớp dữ liệu về đường giao thông là kiểu đường, lớp dữ liệu về loại đất là kiểu vùng... 

▪
Tùy theo kiểu dữ liệu muốn số hoá là điểm, đường hay vùng mà chúng ta chọn các biểu tượng đồ hoạ tương ứng trong hộp công cụ Drawing. 

▪
Tính chất của các đối tượng này (kích cỡ, màu sắc, kiểu dạng...) được xác định với các biểu tượng trong cửa sổ này hay trong Option -> Line Style/ Region Style/ Symbol Style. Ta cũng có thể nhập văn bản với kiểu chữ, kích cỡ, màu sắc và độ nghiêng tùy chọn tại một vị trí bất kỳ. 

▪
Để số hoá các đối tượng tiếp giáp nhau cùng chung một ranh giới, nên sử dụng khả năng bắt điểm (snap to node) bằng cách nhấn phím S để mở/ tắt chế độ bắt điểm này hoặc nhấn thêm phím Ctrl, Shift đề bắt nhiều điểm hay điểm ở lớp dưới. Các chức năng xoá, cắt, nối ghép, xoá phần ngoài, chia cắt các đối tượng địa lý cũng được sử dụng trong quá trình số hoá. 

3.2.3 Ví dụ về số hoá đưòng giao thông và sông ngòi
▪
Chọn Map -> Layer control, đánh dấu chọn vào cột chỉnh sửa ở hàng Cosmetic Layer, chọn OK.

▪
Chọn công cụ vẽ đường gấp khúc Polyline [image: image31.jpg]


 để vẽ các đường giao thông (những đường liền có màu trắng hay màu tím trên ảnh)
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Chú ý : Lớp đường giao thông được vẽ bao gồm nhiều đối tượng, tức là nhiều đường khác nhau. Để tiện lợi cho việc xử lý thông tin sau này, ta nên vẽ như sau: khi vẽ đến ngã 3 hay ngã 4, tức là nơi gặp nhau của 2 hay 3 đường thì ta kết thúc đường thứ nhất, từ điểm giao lộ ta vẽ tiếp đường thứ hai, kết thúc đường này hoặc kết thúc khi gặp một giao lộ khác, quay lại điểm giao lộ đầu tiên và vẽ tiếp đường thứ ba. Nói một cách tổng quát, ta kết thúc vẽ đối tượng đường khi gặp giao lộ, hoặc nếu bắt đầu vẽ từ giao lộ hướng ra, thì có bao nhiêu đường hướng ra ta nên vẽ bấy nhiêu đồi tượng. Ngay cả khi trong thực tế một đường giao thông khi chạy qua giao lộ thì phía bên kia giao lộ vẫn là đường đó (cùng tên) nhưng ta cũng nên tách nó làm hai.
▪
Sau khi vẽ xong các đường giao thông, chọn Map -> Save cosmetic objects và đặt tên cho một lớp mới, ví dụ giao_thông, rồi click save.
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▪
Sông hay suối cũng là các đối tượng kiểu đường như các đường giao thông, hoặc có thêm các đối tượng kiểu vùng, chẳng hạn như hồ, ao…Và  cách số hoá vẫn giống như cách ta thực hiện đối với lớp đường giao thông, cũng là chọn kiểu Polyline [image: image33.jpg]


  để vẽ đối tượng ở dạng đường hay Polygon  [image: image34.jpg]


 để vẽ đối tượng ở dạng vùng. Sau khi số hoá xong lớp sông suối, ta cũng lưu lại thành một lớp riêng có tên là Sông_suối.



CHƯƠNG 3: TỔ CHỨC DỮ LIỆU 

Thông tin mang tính địa lý trên một vùng lãnh thổ bao gồm rất nhiều lớp dữ liệu chuyên đề khác nhau (thuộc đơn vị hành chính nào, trên loại đất nào, hiện trạng sử dụng đất là gì...) và mỗi dữ liệu chuyên đề thường được xây dựng thành một lớp dữ liệu riêng với bản đồ tương ứng. 

Sau khi xây dựng các lớp dữ liệu (table) từ số hoá các bản đồ, thể hiện các đối tượng địa lý trong vùng khảo sát, MapInfo có khả năng bổ sung các số liệu phi không gian (số liệu thuộc tính-yếu tố kinh tế xã hội) bằng nhiều cách. 


Trong quá trình làm việc, MapInfo thường tạo ra các lớp dữ liệu tạm thời (selection) lưu trong bộ nhớ với tên bắt đầu là Query và tiếp theo là số thứ tự, ví dụ: Query1, Query2 v.v..., để có thể sử dụng các dữ liệu này thì chúng ta phải lưu vào đĩa với File -> Save As rồi đặt tên cho lớp dữ liệu tạm thời muốn lưu. 
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Browser của Dis_pol
1. Thay đổi cấu trúc dữ liệu 

▪
Vào Table -> Maintenance -> Table Structure, chọn lớp dữ liệu muốn chỉnh sửa, cửa sổ Modify Table Structure xuất hiện (giống như cửa sổ New Table Structure). 
▪
Click Add Field để thêm cột với tên và kiểu được khai báo tiếp theo. 
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▪
Muốn sửa đổi các tính chất của một vùng đã khai báo, dịch chuyển thanh sáng đến vùng này và chọn tính chất (tên, kiểu) muốn thay đổi. Có thể sắp xếp lại thứ tự các vùng với nút lệnh Up hay Down để di chuyển một cột lên trên hay xuống dưới (lên phía trước hay lui về sau). Cũng có thể loại bỏ một cột bằng cách chọn cột đó và nhấn nút lệnh Remove Field.

2. Cập nhật và bổ sung dữ liệu 
2.1 Bổ sung số liệu thống kê 

Mỗi tính chất của các đối tượng được bổ sung vào một vùng mới và tùy theo kiểu số liệu để khai báo thích hợp trong kiểu vùng. Có thể nhập số liệu trực tiếp trong MapInfo. Vào Windows -> New Browzer Window, chọn lớp dữ liệu muốn bổ sung thêm, sẽ xuất hiện một cửa sổ dữ liệu (Browser) liệt kê dữ liệu theo hàng và cột, nhập số liệu vào các ô thích hợp. 


Để có thể sử dụng các phần mềm khác như Excel chẳng hạn để nhập các số liệu này, phải lưu lớp dữ liệu dạng dBASE.DBF với một tên khác. Vào File -> Save File As Type chọn lớp dữ liệu cần lưu, trong cửa sổ Save File As Type là dBASE.DBF ta sẽ có một tập tin của lớp dữ liệu tương ứng với phần mở rộng là .dbf. Vào Excel  mở tập tin này để cập nhật. Lưu ý là không được thay đổi vị trí của các hàng, vì MapInfo đã lưu thông tin về các đối tượng địa lý đồ hoạ theo thứ tự của các hàng. Chúng ta cũng có thể vào Table -> Export để xuất một lớp dữ liệu sang dạng dBASE (chỉ xuất dữ liệu thuộc tính). 

2.2 Bổ sung dữ liệu do MapInfo tính toán được 

Trong MapInfo với các hàm và các phép toán chúng ta có thể xác lập các biểu thức tính toán tự động trên từng đối tượng (các hàng trong bảng). Biểu thức trong MapInfo bao gồm tên vùng của lớp dữ liệu được mở - trong đó obj là tên vùng đặc biệt chỉ đến đối tượng địa lý của các hàng trong bảng dữ liệu - các toán tử và các hàm. 

▪

Các toán tử trong MapInfo bao gồm theo mức độ ưu tiên:
-
() ; ^ ; dấu âm (-) ; * và / ; + và - ; 
-
Contains, contains entire, within, entirely within, intersects (các toán tử dùng cho đối tượng địa lý); 

-
=, <>, <, >, <=, >= (các toán tử so sánh); 

-
not ; and ; or (các toán tử luận lý).
Các hàm của MapInfo, có dạng tên hàm (tham số), bao gồm:  

▪

Các hàm toán học: 

Abs (số): trả về trị tuyệt đối của số. 

Cos (số -đơn vị - radian): trả về cosin của số.

Sin (số -đơn vị - radian): trả về sin của số. 

   Tan (số -đơn vị - radian): trả về tang của số. 

Int (số): trả về phần nguyên của số.

Maximun (số 1, số 2): trả về số có giá trị lớn hơn.

Minimun (số 1, số 2): trả về số có giá trị bé hơn. 

Round (số 1, số 2): trả về số 1 sau khi làm tròn theo mức số 2 (số 2 có các giá trị như: 0.01, 0.1, 1, 10, 100...) 

▪

Các hàm chuỗi ký tự: 

Str$ (biểu thức): trả về chuỗi ký tự tương ứng của biểu thức. 

Chr$ (số): trả về ký tự tương ứng theo mã ASCII. 

InStr (số, chuỗi 1, chuỗi 2): tìm trong chuỗi 1 bắt đầu từ vị trí số, nếu có chuỗi 2 thì trả về vị trí chuỗi 2, nếu không có thì trả về số 0. Để bắt đầu từ chuỗi 1, số sẽ là 1.

Ltrim$ (chuỗi): trả về chuỗi sau khi cắt bỏ các khoảng trắng phía trước.

Lcase$ (chuỗi, số): trả về chuỗi với chữ thường.

Left$ (chuỗi, số): trả về chuỗi với số ký tự bên trái.

Mid$ (chuổi số 1, số 2): trả về chuỗi bắt đầu từ vị trí số 1 và dài số 2 ký tự của chuỗi.     Proper$ (chuỗi): trả về chuỗi với ký tựđầu là chữ hoa.

Right$ (chuỗi, số): trả về chuỗi gồm số ký tự từ bên phải. 

Rtrim$ (chuỗi): trả về chuỗi sau khi cắt hết khoảng trắng bên phải

Ucase$ (chuỗi): trả về chuỗi chữ hoa. 

Len (chuỗi): trả về số ký tự của chuỗi.

Val (chuỗi): trả về giá trị bằng số của chuỗi. 
▪
Các hàm ngày tháng: 

Curdate (): trả về tháng/ngày/năm của ngày hôm nay.

Day (tháng/ngày/năm): trả về ngày của tháng/ngày/năm. 

Month (tháng/ngày/năm): trả về tháng của tháng/ngày/năm. 

Year (tháng/ngày/năm): trả về năm của tháng/ngày/năm.

Weekday (tháng/ngày/năm): trả về thứ tự của ngày trong tuần của tháng/ngày/năm. Chủ nhật có số thứ tự là 1. 
▪
Các hàm liên quan đến đối tượng địa lý: 

Area (obj,"donvi"): trả về diện tích của đối tượng theo donvi.

CentroidX (obj): trả về trị số kinh độ của điểm trọng tâm của đối tượng. 

CentroidY (obj): trả về trị số vĩ độ của điểm trọng tâm của đối tượng. 

Distance (x1, y1, x2, y2, "donvi"): trả về giá trị khoảng cách giữa hai điểm có toạ độ là (x1, y1) và (x2, y2) theo đơn vị đã ghi. 
ObjectLen (obj, "đơn vị"): trả về giá trị chiều dài của đối tượng theo đơn vị đã ghi. Chỉ cho đối tượng đường hay đa giác. 

Perimeter (obj, "đơn vị"): trả về giá trị chu vi của đối tượng theo đơn vịđã ghi. Chỉ cho đối tượng đa giác hay ellipse. 


Ngoài MapInfo còn có một số từ khoá có thể dùng trong các biểu thức: any, all, in và between ... and. Ví dụ:

 -
Field_x =  any  ("TX.KONTUM", "NH","DH") 

 -
Field_x  in  ("TX.KONTUM", "NH","DH") 

=> tất cả các đối tượng mà cột field_x có giá trị là "TX.KONTUM", hay "NH", hay "DH".

 -
Field_x <>  all  ("TX.KONTUM", "NH","DH") 

 -
Field_x  not in all  ("TX.KONTUM", "NH","DH") 

=> tất cả các đối tượng mà cột field_x có giá trị không là "TX.KONTUM", hay "NH", hay "DH".

 -
Field_x  between 1000 hay 10000 

=> tất cả các đối tượng mà cột field_x có giá trị trong khoảng từ 1000 đến 10000.
 ▪
Đơn vị tính chiều dài: mi(miles), in(inches), ft(feet), yd(yard), km, m, cm, mm,... 

 ▪
Đơn vị tính diện tích: sq mi (square miles), sq in (square inches), sq ft (square feet), sq yd (square yard), acre, sq km (km²), sq m (m²), sq cm (cm²), sq mm (mm²), hectare... 

 ▪
Với Update Column, chúng ta cập nhật hay bổ sung từng cột dữ liệu một. Vào Table -> Update Column, cửa sổ Update Column xuất hiện với các mục như sau: 

- Table to Update: chọn lớp dữ liệu muốn cập nhật trong số các lớp dữ liệu đã mở. 

- Get value from Table: lấy giá trị từ lớp dữ liệu nào? Có hai trường hợp: 

A. Từ lớp dữ liệu muốn cập nhật: 

-
Column to Update: chọn vùng muốn cập nhật. 
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-
Value: nhập một biểu thức hợp lệ. Thường sử dụng khung Assist để xây dựng biểu thức. 

B.
Từ một lớp dữ liệu khác: 

-
Nhấn chuột mục Joint để xác định vùng tham chiếu liên kết giữa hai lớp dữ liệu. 

-
Column to Update: vùng có sẵn hay một vùng mới (add new temporary column).

-
Calculate: Tính toán (có thể là: Value, hay các biểu thức tổng hợp như: Average, Count, Maximum, Sum, Weighted Average (trung bình gia trọng) Proportion Sum (tổng số theo tỷ lệ), Proportion Average (trung bình theo tỷ lệ) và Proportion Weighted Average (trung bình gia trọng theo tỷ lệ). 
 Ghi chú: các biểu thức Average, Count, Minimum, Sum,Weight Average có tham số là các giá trị của dữ liệu, các biểu thức tỷ lệ (Proportion) thì xử lý các đối tượng địa lý.
-
Of : thường là một cột hay một biểu thức hợp lệ. Sau cùng, Nhấn OK để tiến hành cập nhật. 

Ví dụ: 
 Calculate: Value 

 Trong trường hợp  ta muốn cập nhập số liệu dân số (danso) của huyện từ cột Danso trong lớp (layer) của table Huyenhc.tab vào cột Danso trong file Thixa.tab thông qua liên kết Join là Ma_huyen của 2 file trên như hình dưới đây. 
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Kết quả cập nhật cột "Danso" của Table "Thixa" được thể hiện ở hình sau :
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3. Chọn và kết hợp dữ liệu theo điều kiện 
3.1 Chọn các đối tượng theo điều kiện trong một lớp dữ liệu 


Vào File -> Open để mở lớp dữ liệu cơ sở. Sau đó vào Querry -> Select, khai báo các mục trong cửa sổ select như sau: 

▪
Mục Select Records from Table : Click vào khung này và chọn lớp dữ liệu tương ứng. 

▪
Mục That Satisfy : nhập một biểu thức luận lý hợp lệ - thường chọn Assist để xây dựng và kiểm tra biểu thức này. 

▪
Mục Store Results in Table : Nhập tên cho lớp dữ liệu thoả điều kiện trên. Có thể giữ mặc định là Selection. Muốn lưu lớp dữ liệu này phải vào File -> Save As để lưu vào thư mục tên tập tin tùy chọn. 

▪
Trong mục Sort Results by Column :  nhấn chuột vào mục này và chọn tên vùng muốn sắp theo thứ tự. Mặc định là None (không). 
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▪
Đánh dấu vào Browse Results để xem kết quả trong một cửa sổ dữ liệu mới.














































































Với chức năng Select, chúng ta xây dựng được một lớp dữ liệu mới theo điều kiện đã đặt ra. Lớp dữ liệu này thường có ít đối tượng (số hàng) hơn nhưng giữ nguyên cấu trúc của dữ liệu (số cột). Dĩ nhiên chúng ta có thể thay đổi cấu trúc này theo ý đồ của chúng ta, nhưng MapInfo còn có một chức năng để thực hiện trực tiếp điều này, đó là SQL Select. 

Sau khi mở một lớp dữ liệu, vào Querry -> SQL Select. Cách khai báo các mục trong cửa sổ SQL Select như sau: 

· Trước hết nên khai báo mục From Table, di chuyển con trỏ vào khung này và nhấn chuột để nhập tên lớp dữ liệu, chúng ta có thể nhập trực tiếp từ bàn phím tên của lớp dữ liệu này nhưng nên nhấn chuột vào mục Table để chọn. 

· Trong mục Select Columns, nếu chọn tất cả các cột thì giữ dấu * (mặc định), nếu chỉ chọn một số cột thì xoá dấu * rồi click vào khung Columns để chọn các cột theo dự định. Ngoài ra chúng ta còn có thể xây dựng các biểu thức tính toán và hình thành thêm các cột mới. Điều này có nghĩa lớp dữ liệu mới sẽ có cột như cũ hay ít hơn và cũng có thể nhiều hơn. 
· Để đặt tên cho một biểu thức để tính toán, chúng ta ghi tên cột trong dấu ngoặc kép ngay sau biểu thức.
Ví dụ: Danso / Dien_tich "Mat_do". 

· Trong mục where Condition, có thể để trống hay nhập một luận lý hợp lệ. 

-
Để trống nếu muốn chọn tất cả các hàng (phần tử địa lý). 

-
Một biểu thức luận lý thì chỉ muốn chọn những hàng phù hợp với luận lý này. 

Để xây dựng các biểu thức tính toán trong SQL Select, ngoài các thành phần thông thường là tên cột, hàm và toán tử. MapInfo còn có thêm các hàm thống kê như: Avg (trung bình cộng), Sum (tổng), Min (giá trị tối thiểu), Max (giá trị tối đa), WtAvg (trung bình gia trọng) và Count (đếm số đối tượng tương ứng). Các hàm thống kê này dược liệt kê trong khung Aggregates. 

· Kế tiếp trong mục Group by Columns, Columns để chọn cột muốn tính gộp cho các giá trị giống nhau (subtotal) trong cột đó. Mặc định là không chọn cột nào. Khai báo trong cột này thường chỉ sử dụng với các hàm thống kê kể trên. 

·  Trong mục Order by Column, nhấn chuột vào mục Column để chọn cột muốn sắp theo thứ tự. Mặc định là không có cột nào được chọn và nếu có thì theo thứ tự tăng dần. Muốn sắp theo thứ tự giảm dần, thêm desc đằng sau tên cột đã chọn. 
Các lớp dữ liệu mới phát sinh từ các hàm thống kê là các lớp dữ liệu tổng hợp của một cột nào đó, chúng được lưu trong query. 

 Ví dụ: Sử dụng lớp dữ liệu Dis_pol.tab 

Select Column : Count(*) “Tong_DVHC", Sum(Dien_tich) "Tong_Dientich" 
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3.2 Kết hợp với một lớp dữ liệu khác 

Để kết hợp hai lớp dữ liệu với các thông tin khác nhau, chúng ta cùng mở hai lớp dữ liệu này, sau đó vào Query -> SQL Select. Trong cửa sổ SQL Select chúng ta sẽ khai báo như sau: 

Mục From Table: Click khung Tables và chọn các lớp dữ liệu để liên kết. 

Sau khi chọn các lớp dữ liệu, trong vùng where Condition sẽ xuất hiện tên cột dữ liệu để liên kết hai lớp dữ liệu với nhau. 

Mục Select Columns: dấu * là chọn tất cả các cột (column) của hai lớp dữ liệu. Click khung Columns và chọn các vùng muốn thể hiện trong một lớp dữ liệu mới. Có thể tạo cột mới với các biểu thức tính toán hay các hàm thống kê.

Các mục khác khai báo: như đã đề cập ở Phần 3.1. 

 Ví dụ: Lớp dữ liệu Dia_ly.tab gồm các đối tượng địa lý là Đon_vi_hanh_chinh, Dien_tich; lớp dữ liệu Tong_hop.tab chứa các số liệu thống kê về dân số của các xã, phường. Hai lớp dữ liệu cùng có cột (trường) Tx_ID nên có thể sử dụng một trong hai cột này để liên kết hai lớp dữ liệu. Mở hai lớp dữ liệu này, vào Query -> SQL Select, sẽ khai báo(*) trong cửa sổ SQL Select trình bày ở hình dưới đây : 
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4. Tùy chọn nội dung cửa sổ dữ liệu 
Khi vào Windows -> New Browser Windows, chọn một lớp dữ liệu, cửa sổ của lớp dữ liệu đó xuất hiện với tất cả các cột và tên cột đúng như đã khai báo trong Table Structure. 

Để chỉ thể hiện trong cửa sổ này những cột theo ý muốn của chúng ta và tên các cột có thể viết lại cho rõ ràng (nhưng không thể ghi dấu tiếng Việt!), vào Browse -> Pick Fields. 
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Ví dụ: Chọn xem dữ liệu của lớp Dis_pol.tab, cửa sổ Pick Fields xuất hiện như sau: 
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Ngoài ra, chúng ta có thể thể hiện thêm các vùng mới bằng cách chọn Expression, thí dụ: So_dan/ Dien_tich. Biểu thức được thêm vào, sau đó sửa lại tiêu đề vùng (mục Name trong khung Edit Browser Column) là “Mat_do” như trong cửa sổ trên.

Ghi chú: Việc sửa đổi tên các tiêu đề vùng này không ảnh hưởng đến dữ liệu và không lưu được trong Worspace, chỉ có giá trị tạm thời khi cửa sổ dữ liệu này còn được mở .Nếu được lưu trong Workspace thì các vùng được chọn để thể hiện vẫn còn tác dụng. 




CHƯƠNG 4: PHÂN TÍCH KHÔNG GIAN
Phân tích không gian là khả năng đặc biệt của các phần mềm hệ thông tin địa lý. Chính khả năng này đã giúp chúng ta xây dựng những bản đồ quy hoạch hay phân tích mới dựa trên các bản đồ đã số hoá. MapInfo cung cấp một số chức năng như kết hợp, chia cắt, xoá một phần đối tượng bản đồ, tạo vùng đệm của một đối tượng hay tạo điểm chung của hai đối tượng. Các chức năng này được thực hiện cho các đối tượng trong cùng một lớp dữ liệu hay trên hai lớp dữ liệu khác nhau. Các đối tượng này thường phải xử lý được. 
1.  Kết hợp các đối tượng địa lý 
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Chức năng kết hợp (Combine) không cần thiết phải chọn đối tượng xử lý được, chúng ta chọn các đối tượng muốn kết hợp với nhau sau đó vào Objects -> Combine. Cửa sổ Data Aggregation xuất hiện với các tham số sau: 
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2. Xoá phần đối tượng được xử lý nằm bên trong hay ngoài đối tượng chuẩn 
Sau khi xét một (hay nhiều) đối tượng xử lý được, chúng ta chọn một hay nhiều đối tượng làm chuẩn (bắt buộc là có kiểu đa giác) mà chúng ta muốn xoá (Erase) một phần đối tượng xử lý được khi phần này nằm bên trong ranh giới của đối tượng làm chuẩn. Sau khi chọn xong (đối tượng cần xử lý phải ở chế độ Set Target), vào Objects -> Erase. Trường hợp đối tượng xử lý được kiểu đa giác, sẽ xuất hiện cửa sổ Data Desaggregation tương tự như cửa sổ ở trên, chỉ khác ở trong khung Desaggregation Method có Area Proportion có nghĩa là sẽ tính giá trị theo tỷ lệ diện tích của đối tượng mới so với đối tượng cũ. 

[image: image134.jpg]Create Thematic Map - Step 2 of 3

Select a Table and a Field:

Table: [Hupert 5

Fied: [Dien_fich 5

¥ Ignore Zeross or Blrks




[image: image135.jpg]Create Thematic Map - Step 3 of 3

Preview: Customize:
Huyent by Dien_fich

O 138000t0241 000 (2)
O ssoo0to138000 (3)
4300010 85000 (4)

Rangss.

Siyls.

il

Legend
























































[image: image136.jpg]Huyen1 Map

Chi din
D¥en tch cc huyen
[0 241000 0eh 241000

0 “ss000aen 138,000
O 4300006 55000




Ngược với trường hợp trên, để xoá phần đối tượng xử lý nằm bên ngoài đối tượng chuẩn (cũng bắt buộc là kiểu đa giác), chúng ta sau khi xét Object -> Erase Outside và khai báo thích hợp trong cửa sổ Data Desaggregation. Kết quả như sau: 

3. Cắt chia đối tượng được xử lý theo ranh giới của các đối tượng chuẩn 
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Trường hợp này sẽ chia cắt đối tượng được xử lý thành 2 (hay nhiều) vùng: Vùng (các vùng) có đối tượng chuẩn và vùng không có đối tượng chuẩn. Tương tự như trên, nhưng sau khi chọn đối tượng được xử lý và đối tượng chuẩn, chúng ta vào Option -> Split.
4. Một số chức năng khác 
Ngoài 3 cách xử lý chính như trên, MapInfo còn có một số chức năng khác như: 

4.1 Tạo vùng đệm bao quanh một (hay nhiều) đối tượng 
Đối tượng có thể là điểm, đường hay đa giác. Vùng đệm là một đối tượng mới trong lớp dữ liệu chứa đối tượng chuẩn, dĩ nhiên lớp dữ liệu này có thuộc tính sửa đổi được (Editable). 
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Trước hết chúng ta chọn (các) đối tượng muốn tạo vùng đệm sau đó vào Object -> Buffer, cửa sổ Buffer Object xuất hiện như sau. 

-
Value ......................................... Giá trị bề rộng vùng đệm, phụ thuộc vào mục Units (đơn vị) ở dưới. 

-
From Column ............................ Có thể khai báo giá trị bề rộng là giá trị của một cột nào đó của lớp dữ liệu. Sử dụng trong trường hợp giá trị của Value thay đổi theo từng đối tượng. 

-
Units .......................................... Có thể là km, m, cm... 
-
Smoothness (Sự phẳng liền) ...... Nhập sốđoạn tạo nên một vòng tròn. Số đoạn càng nhiều thì đường ranh của vùng đệm càng phẳng liền (ít gãy khúc). Số đoạn mặc định là 12, nhưng có thể tăng lên 20 hoặc 24. 
-
One buffer for all object ............ Tạo ra 1 vùng đệm chung. 
-
One buffer for each object ......... Tạo ra 1 vùng đệm cho mỗi đối tượng (có thể nhiều vùng đệm được tạo ra. 

4.2 Kết hợp các đối tượng cùng giá trị trong một cột 
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4.3 Định vị dữ liệu trên bản đồ 
Chức năng Query -> Find dùng để định vị từng đối tượng của lớp dữ liệu trong cửa sổ bản đồ. Khi vào Query -> Find, sẽ xuất hiện cửa sổ Find và chúng ta khai báo như ví dụ ở hình bên dưới :
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Khai báo trong Find :
- For Objects in Column: Chỉ chọn được cột đã lập chỉ mục (index). 

- Nhấn vào mục Mark with symbol đểđặt dạng, màu và kích cỡ đối tượng. 
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- Nhấn OK, sẽ xuất hiện tiếp cửa sổ Find thứ 2 với 1 khung để nhập giá trị của cột chỉ mục được sử dụng. Trường hợp không nhớ giá trị này, chúng ta nhấn OK để hiện bảng danh sách các giá trị của các chỉ mục và chúng ta di chuyển chuột để chọn giá trị mong muốn, chọn xong nhấn OK. Đối tượng tương ứng được đánh dấu trong cửa sổ bản đồ và ghi trên lớp dữ liệu tạm thời "Cosmetic Layer". 
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- Nếu chúng ta muốn đánh dấu tiếp, chúng ta lại vào Query -> Find, nhưng từ lần thứ hai sẽ xuất hiện ngay cửa sổ Find thứ nhì, không xuất hiện lại cửa sổ Find ban đầu. Trường hợp chúng ta muốn trở lại cửa sổ Find ban đầu để khai báo một cột khác chẳng hạn, chúng ta nhấn vào mục Respecify. 
4.4 Phân vùng lãnh thổ khảo sát (Redistrict) 
Đây là một quá trình tập hợp các đối tượng địa lý và sau đó tính toán tổng giá trị của các cột dữ liệu cho mỗi tập hợp được hình thành. Một ưu điểm của quá trình này là giá trị của các vùng tự động điều chỉnh khi chúng ta thêm hay bớt một hay nhiều thành phần của chúng. Điều này giúp chúng ta phân vùng một cách linh động đáp ứng với một tiêu chuẩn nào đó. 

Việc phân vùng này không tạo nên đối tượng địa lý mới hay làm thay đổi kiểu của chúng. Nó chỉ là công cụ tạo nhóm năng động nhằm thể hiện các đối tượng được gom nhóm trên bản đồ cùng với những thông tin liên quan. Chúng ta có thể phân vùng cho các đối tượng kiểu vùng, kiểu đường hay kiểu điểm, nhưng số vùng được hình thành không quá 300. 

Quá trình sắp xếp đối tượng vào các vùng làm thay đổi giá trị của các đối tượng trong cột dữ liệu được chọn, vì vậy để không làm ảnh hưởng đến các số liệu đã có chúng ta nên tạo một cột mới dành riêng cho việc phân vùng này. 
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 Sau khi mở lớp dữ liệu, chúng ta vào Window -> New Redistrict Window. Cửa sổ New Redistrict Window xuất hiện, cách khai báo các tham số trình bày theo hình dưới. 

-  Source Table: Nhập tên lớp dữ liệu nguồn – ở ví dụ trên là Dis_pol.tab

- District Filed: Nhập tên cột làm cơ sở phân vùng – như trên ta chọn cột Don_vi_hanh_chinh. 

- Trong khung Filed to Browse mặc định sẽ liệt kê tên cột đã khai trong District Field, Count (số đếm các đối tượng trong một vùng), Fill (tô màu – trường hợp đối tượng kiểu đa giác). Ta thêm 2 cột là sum(Dien_tich) “tổng diện tích” của tất cả các xã, phường và cột sum(Dan_so) “tổng dân số”. 

- Trong khung Available Filed sẽ liệt kê các tham số tổng hợp như tổng hay giá trị phần trăm của các cột dữ liệu. Chúng ta sẽ dùng Add hay Remove để thêm bớt các cột dữ liệu tổng hợp muốn thể hiện.Với ví dụ trên ta có bảng kết quả sau. 
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CHƯƠNG 5: BIÊN TẬP VÀ KẾT XUẤT BẢN ĐỒ
Khi chúng ta có các lớp dữ liệu riêng biệt về một khu vực lãnh thổ, chúng ta có thể xây dựng các bản đồ chuyên đề khác nhau. Biên tập bản đồ trên máy tính là kết hợp các lớp dữ liệu đã được số hoá, sắp xếp thứ tự, tô màu và xét thuộc tính cho các đối tượng, chú thích... cũng như sắp xếp vị trí của chúng để có thể in ra giấy. Chúng ta sẽ sử dụng các chức năng trong mục Map trên menu chính. 

Trước hết vào File -> Open Table, chọn mở các lớp dữ liệu cần thiết cho bản đồ chuyên đề dự định xây dựng. Dĩ nhiên các lớp dữ liệu này cũng liên quan đến một khu vực địa lý và cùng hiện trên một cửa sổ bản đồ (Map Window). Ví dụ ta mở một số lớp bản đồ như hình bên dưới: 
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1. Sắp xếp thứ tự các lớp dữ liệu 
Chức năng này được thực hiện trong cửa sổ Layer Control (vào Map -> Layer Control hay click biểu tượng [image: image39.jpg]


  tương ứng khi đang làm việc trên một cửa sổ bản đồ.  Thông thường tất cả các lớp dữ liệu đã được mở đều xuất hiện trong vùng Layer trên cửa sổ Layer Control, nhưng đôi khi về tỷ lệ vùng nhìn lớn nên có thể nằm ngoài giới hạn của một lớp dữ liệu nào đó nên lớp dữ liệu này không hiện diện trong cửa sổ bản đồ hoạt động, để thêm một lớp dữ liệu đã mở vào một cửa sổ bản đồ nhấn chuột vào mục Add trong khung Layer của cửa sổ Layer Control, chọn trong cửa sổ Add Layer các lớp dữ liệu muốn thêm và nhấn chuột vào mục Add. 
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Để thay đổi thứ tự các lớp dữ liệu, chọn từng lớp dữ liệu và sử dụng button "Up" hay "Down" trong khung Reoder để đưa lớp dữ liệu đó lên hoặc xuống. Điều này cũng rất quan trọng vì có thể lớp dữ liệu bạn mỡ có thể nằm ở dưới một lớp vùng nào đó và không thể hiện được, trong trường hợp này bạn phải di chuyển lớp này lên phía trên. Trong ví dụ trên lớp “Song_suoi” bi lớp “Giao_thong” che khuất 
2. Thay đổi các thể hiện của đối tượng 
Thường áp dụng cho những lớp dữ liệu "phụ" của bản đồ (đối với lớp dữ liệu chuyên đề chính sẽ trình bày sau) với khung Display trong cửa sổ Layer Control. Chức năng này nhằm gán tạm thời các thuộc tính về thể hiện cho các đối tượng địa lý của một lớp dữ liệu. Chọn lớp dữ liệu muốn thay đổi thuộc tính thể hiện, rồi chọn Display, cửa sổ Display Options của lớp dữ liệu được chọn xuất hiện với cách khai báo như sau: 

 - 
Khung Dislay Mode: Xuất hiện đủ các kiểu đối tượng của lớp dữ liệu (kiểu điểm, đường, vùng hay văn bản). Muốn gán thuộc tính để thể hiện tạm thời cho một (hay tất cả) trong các kiểu, chúng ta phải nhấn chuột vào ô vuông trống phía trước chữ Style Override. Sau đó nhấn chuột vào từng kiểu đối tượng. 


+ Kiểu điểm: Các khung trong cửa sổ Symbol Style cho phép chúng ta chọn dấu hiệu trong lớp font chữ, kích cỡ và màu sắc. Chúng ta còn có thể xét độ nghiêng (góc quay) cũng như một sốđặc tính khác như khung viền, bóng nổi… 

+ Kiểu vùng: Với kiểu vùng này chúng ta có thể cài đặt kiểu tô (hoa văn và màu nền) và kiểu đường bao quanh (liền nét, đứt đoạn… màu sắc và độ rộng). 


+ Kiểu đường: Chúng ta khai báo trong cửa sổ Line Style để chọn các thuộc tính như kiểu (liền nét, đứt đoạn, chấm gạch…), màu sắc và độ rộng. 
+ Kiểu văn bản: Chúng ta có thể xét font chữ, cỡ chữ và màu sắc, ngoài ra còn xét dạng của nền văn bản là không (none), nền từng chữ hay nền chung cho đoạn văn bản cùng với màu sắc của nền. 
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-
Khung Zoom Layering để xét cho lớp dữ liệu được thể hiện trên cửa sổ bản đồ khi cửa sổ bản đồ có một mức độ phóng đại nào đó chúng ta xác định. 
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3. Ghi chú trên bản đồ 
Chúng ta có thể ghi văn bản một cách tự do trong cửa sổ bản đồ với font, cỡ, màu và độ nghiêng của chúng. Tuy vấn để có thể ghi chú thống nhất cho các đối tượng của lớp dữ liệu, MapInfo cho phép chúng ta định dạng thích hợp cho mỗi lớp dữ liệu. Để định dạng các ghi chú này chúng ta nhấn chuột vào khung Label trong cửa sổ Layer Control. 
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Trước hết chúng ta xét nội dung của ghi chú trong khung Label with. Chúng ta có thể chọn giá trị các cột của lớp dữ liệu hoặc là một biểu thức dạng chuỗi. 
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- Trong khung Position mục Anchor Point dành để chọn vị trí của ghi chú đối với trọng tâm của kiểu vùng và mục Label with Line (quay ghi chú theo chiều của đoạn được chọn). Mục Label Offset 2 Points cho biết trị số về khoảng cách giữa ghi chú và điểm neo (ảnh point), chúng ta có thể thay đổi trị số này nếu thấy cần. 
- Chúng ta có thể xoá từng ghi chú bằng cách chọn chúng (Select) rồi bấm Delete, nhưng để xoá tất cả các ghi chú chúng ta vào Map -> Clear Custom Labels. 

- Các ghi chú này chỉ được lưu lại trong workspace. 

4. Biên tập bản đồ chuyên đề 
Vào Map -> Create Thematic Map để biên tập các lớp bản đồ chuyên đề. 
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MapInfo có 7 cách trình bày một bản đồ chuyên đề tùy theo dữ liệu muốn thể hiện. Để thể hiện từng dữ liệu một, có thể sử dụng Ranges, Graduated, Dot Density hay Individual và để thể hiện nhiều dữ liệu một lúc chúng ta sử dụng Bar Charts hay Pie Charts 
Để thể hiện các đối tượng một cách độc lập, có nghĩa có thể phải xét màu sắc, kích cỡ, hình dáng cho từng đối tượng, chúng ta vào Individual. 

4.1 Individual 
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Chọn mục Individual, chọn kiểu Template -> Name và nhấn chuột vào ô Next, sẽ xuất hiện cửa sổ Create Thematic Map – Step 2 of 3 để chúng ta chọn tên lớp (Table) và cột (Field) dữ liệu muốn xây dựng thành bản đồ. Ở ví dụ phía dưới ta chọn Table là Huyen1.tab  và Field là Huyen. 
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Tùy theo số trường hợp khác nhau có thể hiện được trên bản đồ mà chúng ta thường phân cấp các đối tượng cho phù hợp và việc phân cấp này thường được sắp xếp trong một cột mang ý nghĩa mã số, có nghĩa số đối tượng của mỗi cấp thường là khác nhau. với một lớp dữ liệu chúng ta có thể thực hiện việc phân cấp nhiều lần (tạo nhiều cột ghi mã số) tùy theo cách khai thác số liệu. Chúng ta có thể không xét những đối tượng có giá trị của một cột đã chọn là 0 hay để trống bằng cách đánh vào ô trống phía trước dòng Ignore Zeroes or Blanks. Sau khi chọn cột dữ liệu mà MapInfo phân thành các cấp khác nhau tùy theo giá trị của cột, nhấn vào ô Next. 
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Để thay đổi nội dung của chú thích, click chuột vào khung Legend, cửa sổ Customize Legend xuất hiện với các mục sau:
 
- Trước hết là đề tựa của chú giải và chúng ta có thể xét font, cỡ và màu sắc của đề tựa này trong 2 mục Tittle và Subtittle (tựa chính và tựa phụ). Trong nội dung chú giải cho các cấp (Range Labels) thì MapInfo cũng cho phép chúng ta định dạng cho kiểu văn bản, đồng thời sửa đổi nội dung mặc định là giá trị của các cấp. Khai báo và sửa đổi xong -> nhấn OK để xác nhận. Nếu muốn chọn các khai báo này là mặc định (để dùng thống nhất cho các lần sau) chúng ta nhấn chuột vào Save Settings trước khi nhấn OK. 
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Sau khi nhấn OK trong cửa sổ "Create Thematic Map – Step 3 of 3", lớp bản đồ chuyên đề trong cửa sổ bản đồ sẽ được thể hiện như chúng ta đã sắp đặt trong quá trình xây dựng vừa xong cùng với sự xuất hiện của cửa sổ Legend (Chú thích). 

4.2 Ranges (phân hạng) 
[image: image164.jpg]Export Table to File.

Savein: | 3 Workspace ~

(Dertinz
(=10
(Dimgrdz
(Dimgrds
Bmgraz
Qinfo
(D lamha
(Stingrid
(Dtingridz

o = Sae
R P | Cance

 Maplrio Places
© Standard Places




Ở mục Create Thematic Map, nếu chúng ta chọn khung Ranges và click Next thì cửa sổ Create Thematic Map – Step 2 of 3 xuất hiện cũng để cho chúng ta khai báo tên và cột dữ liệu.
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 Sau đó trong cửa sổ Create Thematic Map – Step 3 of 3, sẽ xuất hiện thêm ô Ranges trong khung Customize. Để thay đổi số cấp cũng như xét lại giới hạn của các cấp chúng ta nhấn vào mục Ranges. 
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 Trong cửa sổ Customize, trước hết chúng ta khai báo ở mục Method (phương pháp). Thông thường chúng ta chọn phương pháp Custom để tùy tiện khai báo các tham số liên quan. Chúng ta sẽ khai báo tiếp về số cấp trong mục # of Ranges và để thay đổi giới hạn của mỗi cấp chúng ta sẽ khai báo lại trong khung Custom Ranges. Khi các trị số này thay đổi thì giá trị tương ứng trong khung liệt kê ở phía trên cũng thay đổi. Nhấn vào mục Recalc sẽ hiển thị trong khung liệt kê tỷ lệ và số đối tượng của mỗi cấp. Chúng ta có thể khai báo lại từ đầu để kết quả đạt được theo dự kiến. Sau cùng click OK để xác nhận. 
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Trong khung Preview của cửa sổ Create Thematic Map – Step 3 of 3 chúng ta thấy màu các cấp thay đổi theo độ đậm nhạt dần, và chúng ta có thể thay đổi chúng cũng như các chú thích như đã đề cập ở trên. 

4.3 Graduated và Dot Density (độ lớn của dấu hiệu hay độ dày của điểm) 

Chọn mục Graduated hoặc Dot Density trong cửa sổ Create Thematic Map – Step 1 of 3 và click Next, cửa sổ Create Thematic Map – Step 2 of 3 xuất hiện để chúng ta chọn tên lớp và cột dữ liệu ( cũng với file huyen.tab và field Dien_tich).
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Tương tự như với Ranges, nhưng trong khung Customize của cửa sổ Create Thematic Map – Step 3 of 3 thì ô Settings thay cho ô Ranges và khung Styles không hoạt động. 

· Trường hợp chọn Graduated, khi click ô Settings sẽ xuất hiện cửa sổ Customize Graduated Symbols với các mục: 

-  Symbol: Để xét hình dạng, kích cỡ và màu sắc của dấu hiện thể hiện. 

- At Value: nhập giá trị tương đương với độ lớn của dấu hiệu đã chọn. 
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- Trong khung Options sẽ cho phép chúng ta xét dấu hiệu cho các giá trị âm cũng như cách thức MapInfo thể hiện sự biến thiên của các dấu hiệu tùy theo giá trị của cột dữ liệu là Square Root, Constant hay Log. MapInfo khuyến cáo nên chọn cách Square Root nó thể hiện tỷ lệ biến đổi vừa phải, theo diện tích của dấu hiệu. 

· [image: image171.jpg]


Trường hợp chọn Dot Density, sau khi chọn ô Settings, xuất hiện cửa sổ Customize Dot Density Settings, và chúng ta sẽ khai trước hết mục Each Dot Represent…units là giá trị tương ứng của cột dữ liệu ứng với một điểm thể hiện. Kế là chúng ta xét kích cỡ của các điểm là lớn hay nhỏ (Large hay Small). 


4.4 Bar Charts hay Pie Charts (biểu đồ cột hay biểu đồ bánh) 
Khác với 4 kiểu đã thảo luận trước chỉ khảo sát trên một cột dữ liệu, 2 kiểu này nhằm thể hiện phối hợp giá trị của nhiều cột dữ liệu. 




Trường hợp Bar Charts, trong cửa sổ Customize Bar styles chúng ta chọn quy cách của dấu hiệu cho các cột (chủ yếu là xét màu). Chúng ta sẽ chọn tiếp cách thể hiện là chồng nhau (stacked) hay sắp kế nhau (multiple bars) với thuộc tính phụ thể hiện tỷ lệ các giá trị là Graduated Stack đối với Stacked và Independent Scales đối với Multuple Bars. Chúng ta xét tiếp theo phần kích thước và tỷ lệ tương ứng của các thanh thể hiện, chúng ta có thể chọn Options để xét thêm một số thuộc tính khác như vị trí thể hiện so với trọng tâm của đối tượng… Tương tự đối với trường hợp Pie Charts. 


Khi đã xây dựng một bản đồ chuyên đề từ một lớp dữ liệu (lưu ý là từ một lớp dữ liệu chúng ta có thể xây dựng nhiều bản đồ chuyên đề), trong cửa sổ Layer Control xuất hiện thêm lớp bản đồ này. Khi chúng ta chọn lớp bản đồ này trong cửa sổ Layer Control khung Thematic trở nên hoạt động, nhấn chuột vào khung này cũng sẽ xuất hiện cửa sổ Modify Thematic Map, chúng ta có thể xoá chúng đi bằng cách chọn lớp bản đồ chuyên đề muốn xoá và nhấn Remove. 

5. Định lưới toạ độ địa lý và tỷ lệ bản đồ
 
MapInfo ngoài chương trình chính còn một số chương trình phụ kèm theo để thực hiện một số chứ năng riềng, trong đó có việc định lưới toạ và chọn tỷ lệ bản đồ. Các biểu tượng trong hộp công cụ Tools thực hiện tương ứng các chức năng liên quan đến các chương trình này. 


Để chạy các chương trình phụ này chúng ta sẽ vào Tools -> Run MapBasic Program, chúng ta sẽ chọn trong cửa sổ Run MapBasic Program tập tin có tên Gridmakr.mbx và Scalebar.mbx trong thư mục phụ Tools (Sub-folder) của thư mục chương trình MapInfo. Một khi chọn chạy chương trình phụ này, trên menu chính xuất hiện thêm mục Tools. Trong mục Tools này, cũng như trong hộp công cụ Tools sẽ xuất hiện thêm tên hay biểu tượng của chương trình MapBasic tương ứng. 

5.1 Định lưới toạ độ địa lý (Gridmakr.mbx) 
Vào Tools -> Grid Makes -> Make Grid..., chúng ta khai báo trong cửa sổ Create Long/ Lat Grid  như sau: 


·  Kiểu (Object Styles): nên chọn kiểu đường để nhìn xuyên qua. 
·  Khoảng cách giữa các đường: Mặc định là 1 độ, nhưng tùy theo quy mô để xét trị số này. Có thể chọn 15’ (phút) (=0,25 hệ thập phân) khi xét ở cấp tỉnh, 10’ (=1,166666) ở cấp huyện và 5’ (= 0,083333) ở cấp xã.
·  Kế tiếp là chọn vùng (Extents). Nên tham chiếu đến phạm vi kinh độ và vĩ độ của vùng theo bản đồ địa hình để khai báo trong mục này

Đối với một vùng đã được số hoá, chúng ta có thể mở một cửa sổ bản đồ của vùng đó, sau đó nhấn chuột lên biểu tượng [image: image40.jpg]


  trong hộp công cụ Tools rồi đưa con trỏ vào trong cửa sổ bản đồ, bấm và kéo chuột một khung chữ nhật trong cửa sổ bản đồ nhằm xác định khu vực làm lưới toạđộ, cửa sổ Create long/ lat grid sẽ xuất hiện và chúng ta sẽ chỉ khai báo kiểu đường hay vùng, độ lớn của ô lưới và đơn vị, còn toạ độ của khu vực đã được xác định tương ứng với vị trí trong cửa sổ bản đồ. 
5.2 Tạo thước tỉ lệ (scalebar.mbx) 
Vào Tools -> Scalebar -> Draw Scalebar, hay click biểu tượng trong hộp công cụ Tools, cửa sổ Draw Distance Scale in Mapper xuất hiện và chúng ta khai báo chiều dài của thanh tỉ lệ Length of Scale Bar theo đơn vị hệ mét hay hệ inch... Chúng ta có thể chọn font và cỡ chữ cũng như kiểu tô trên thanh tỷ lệ. 

 
Thanh tỷ lệ theo chiều dài và dạng thức đã chọn sẽ được vẽ trên lớp bản đồ Cosmetic Layer, chúng ta có thể di chuyển chúng để chọn vị trí thích hợp và lưu thành một lớp dữ liệu riêng với Map -> Save Cosmetic Objects. 

6. Sắp xếp trang in (layout) 
Trang in (layout) là một dạng thể hiện cửa sổ bản đồ hiện hành trên trang giấy in, nội dung của nó tùy thuộc vào nội dung của cửa sổ bản đồ, vì vậy trước khi làm việc với trang in chúng ta nên chuẩn bị tốt cửa sổ bản đồ liên quan. Giả sử chúng ta đã có các lớp bản đồ như hình dưới đây. 
Trước hết là kiểm tra và đặt lại nếu cần khổ và chiều dài của trang in cùng với loại máy in trong File -> Page Setup. 

Vào Window -> New Layout Window (F5), trong cửa sổ này chúng ta có thể chọn:


 - Once Frame for window: để chọn một cửa sổ đã mở trên màn hình. Trường hợp chọn một cửa sổ bản đồ chuyên đề, cửa sổ chú giải cũng được tự đưa vào. 
- Frames for All Currently Open Window: để chọn tất cả các cửa sổ đã được mở trên màn hình. 

- No Frames: không chọn cửa sổ nào (layout trống). 

Nhấn OK, một cửa sổ trang in (layout) xuất hiện và trên menu chính có thêm mục Layout 
Tương tự trong cửa sổ bản đồ, MapInfo cho chúng ta xét vị trí tương đối của khung bản đồ trong cửa sổ trang in bằng cách vào Layout -> Change Zoom, và để xem trọn trang in trong cửa sổ trang in chúng ta sử dụng chức năng View Entire Layout, hay View Actual Size để trang in đúng theo kích cỡ sẽ được in ra. 


Trên cửa sổ Layout chúng ta cũng có thể vẽ thêm các đối tượng cũng như ghi thêm các ghi chú như: Tiêu đề bản đồ, nguồn gốc bản đồ… với các dạng thức rất linh động và sắp xếp chúng với chức năng Align Objects (dóng hàng các đối tượng). Chọn các đối tượng muốn dóng hàng, vào Layout -> Align Objects: 

· Khung Horizontal: để dóng hàng theo chiều đứng . 

· Khung Vertical: để dóng hàng theo chiều ngang. 

Trên trang in chúng ta có thể thêm các nội dung khác như 1 bảng dữ liệu, 1 biểu đồ hoạ hay một cửa sổ bản đồ khác… sẽ được xác định trong cửa sổ Frame Object khi chúng ta chọn biểu tượng Frame [image: image41.jpg]


  trong hộp công cụ Drawing. 

Chức năng Create Drop Shadow trong mục Layout giúp chúng ta tạo một khung viền nổi cho một đối tượng được chọn trên trang in. 

Chúng ta lưu trang in theo dạng Workspace (.wor) bằng cách vào File -> Save Workspace hoặc chọn biểu tượng save workspace [image: image42.jpg]


 và nếu như các bước thực hiện là đúng chúng ta sẽ cho xuất hiện bản để in như hình dưới đây. 


CHƯƠNG 6: MỘT SỐ TIỆN ÍCH KHÁC
1. Thao tác trên các đối tượng 
· Làm tròn góc (Smooth) Object -> Smooth  và trở về nguyên trạng (Unsmooth)  Object -> Unsmooth. Hai chức năng này chỉ thực hiện với đối tượng kiểu đường. Chức năng làm tròn góc (Smooth) sẽ làm tròn các góc của đường gãy khúc và chức năng làm trở về nguyên trạng (Unsmooth) sẽ phục hồi lại nguyên trạng của đối tượng đã được làm tròn góc. 



· Chuyển đổi từ kiểu đa giác thành kiểu đường và ngược lại: Object -> Convert Polylines và Object -> Convert to Regions.  Có lẽ vì chỉ có kiểu đường (line, polyline) mới làm tròn góc được nên để có thể làm tròn một đa giác chúng ta chuyển đổi nó thành kiểu đường (polyline).  Ngoài ra, để sử dụng một đối tượng địa lý cho hai hay nhiều lớp dữ liệu khác nhau với kiểu cũng khác nhau, như một khúc sông vừa có kiểu đường trong lớp dữ liệu sông suối vừa có kiểu vùng trong lớp dữ liệu ranh giới hành chính. Chúng ta chuyển đổi từ kiểu vùng sang kiểu đường để tránh sai số khi số hoá nhiều lần. 
· Tạo giao điểm chung cho các đối tượng lân cận giao nhau: Object -> Ovelay Nodes. Để tạo thêm các điểm trung gian trên một đối tượng xử lý được kiểu đường hay kiểu vùng tại điểm giao tiếp với đối tượng chuẩn kiểu đường hay kiểu vùng. 

2. Thao tác trên các tập tin của lớp dữ liệu (Table) 
Các thao tác dưới đây có thể thực hiện cho các lớp dữ liệu đang được mở: 

2.1 Đổi tên lớp dữ liệu 
Vào Table -> Maintenance -> Rename Table, chọn tên lớp dữ liệu trong cửa sổ Rename Table rồi nhấn vào button Rename, nhập tên mới cho lớp dữ liệu mới trong cửa sổ Rename Table thứ hai. Nếu chúng ta đổi luôn tên thư mục (Folder) thì lớp dữ liệu này sẽ được chuyển đến thư mục đã khai báo. 

2.2 Xoá lớp dữ liệu trên đĩa 


Vào Table -> Maintenance -> Delete Table, Chọn tên lớp dữ liệu muốn xoá trong cửa sổ Delete Table rồi nhấn vào button Delete; nhấn OK trong cửa sổ mới xuất hiện để xoá. 

2.3 Xoá khoảng dung lượng đĩa của các đối tượng đã bị sửa đổi 
Mỗi khi chúng ta thao tác trên trên các đối tượng địa lý như kết hợp lại, chia cắt, sửa đổi vị trí các điểm trung gian… MapInfo sẽ tạo ra một hay nhiều đối tượng mới. Mặc dù đã xoá thông tin của các đối tượng đã được sửa đổi nhưng dung lượng chiếm trên đĩa của các đối tượng này vẫn còn tồn tại. Để xoá khoảng trống vô ích này trong các tập tin, chúng ta vào Table -> Maintenance -> Pack Table. 


Chọn tên lớp dữ liệu trong khung Pack Table, để mặc định các lựa chọn khác rồi nhấn OK. Sau khi thực hiện thao tác này lớp dữ liệu không còn hiện diện trên màn hình nhưng vẫn còn đang mở. Muốn chúng xuất hiện trong một cửa sổ nào đó chúng ta click vào khung Add trong cửa sổ Layer Control [image: image43.jpg]


 của cửa sổ đó, hoặc muốn hiển thị trong cửa sổ bản đồ mới chúng ta nhấn vào Window -> New Map Window. 
2.4 Thể hiện dữ liệu dạng biểu đồ
 
Một khả năng khác của MapInfo là có thể hiển thị số liệu các cột của lớp dữ liệu đang mở theo dạng biểu đồ. Nếu chỉ muốn thể hiện biểu đồ của một số đối tượng (hàng) chúng ta phải chọn các đối tượng đó trước khi vào Window -> New Graph Window (F4).  Trong cửa sổ New Graph Window (cửa sổ biểu đồ) chúng ta sẽ khai báo tên dữ liệu hay các đối tượng đối tượng đã chọn trước (selection), sau đó xác định các cột mà số liệu sẽ được thể hiện trên biểu đồ và cuối cùng là chọn cột để làm tên cho các đối tượng trên. 


Nhấn chuột vào OK, trên màn hình sẽ xuất hiện biểu đồ dưới đây, đồng thời trên thanh Menu cũng xuất hiện thêm Menu Graph (thay cho Map, Browser, hay Layout).  



Để thay đổi cách thể hiện mặc định như trên, chúng ta sẽ sử dụng các chức năng trong mục Graph bao gồm các chức năng như: 

· Graph -> Graph Type. 

· Graph -> Label Axis và Graph -> Value Axis. 
· Graph -> Series. 

2.5 Xuất nhập các dạng dữ liệu để trao đổi với các phần mềm khác 
2.5.1 Xuất (Export) 
 
Các dữ liệu trong MapInfo có thể chuyển thành một số dạng khác như MapInfo chuyển đổi (.mif), dạng Autocad (.dxf), dạng văn bản (.txt) hay dạng cơ sở dữ liệu (.dbf). Thông thường hai dạng .mif và .dxf thông dụng nhất. 




Trong cửa sổ này chúng ta chọn File Format là AutoCAD DXF, và tên tập tin dạng DXF tương ứng với dữ liệu Huyen, xong nhấn Save. Trong cửa sổ DXF Export Information mới xuất hiện, chúng ta nên chọn như sau: 


Nên đánh dấu vào ô Preserve Multi-Polygon Regions as DXF Blocks và Preserver Attribute Data để lưu các thông tin thuộc tính của các đối tượng bao gồm nhiều đa giác. Nhấn OK sẽ tiến hành việc tạo tập tin chuyển đổi theo dạng đã chọn (.dxf). 

2.5.2 Nhập (Import) 
 
MapInfo có thể sử dụng thông tin từ một số dạng khác như dạng AutoCAD DXF, dạng MapInfo chuyển đổi. Sau đây là tiến trình đăng nhập thông tin dạng DXF vào MapInfo. 


Từ menu Tab -> Import, trong cửa sổ Import File chúng ta chọn Import Format là AutoCAD DXF, và tập tin muốn chuyển đổi. 


Nhấn chuột vào Import, xuất hiện cửa sổ DXF Import Information.

Nhấn chuột vào mục Set Transformation để biết đơn vị của toạ độ, sau đó nhấn vào Projection để khai báo phép chiếu phù hợp với vùng địa lý và đơn vị toạ độ địa lý. Trường hợp tập tin dạng DXF có nhiều “layer” chúng ta phải chọn các layer nào muốn chuyển. Đánh dấu vào khung Preserve DXF Blocks và Preserver Attribute Data để sử dụng các thông tin đã có. Nhấn OK và nhập tên file cho lớp dữ liệu chuyển đổi, tập tin này sẽ lưu dưới dạng của MapInfo (.tab). 

Để xem lớp thông tin vừa Import ta vào Map -> New Map Window và Map  -> New Browser Window, rồi chọn tên lớp dữ liệu mới này, trên màn hình sẽ xuất hiện lớp dữ liệu này như hình sau: 


PHỤ LỤC 1

HỆ THỐNG MENU CỦA MAPINFO
1 Menu FILES 

· New Table .............................Tạo ra một lớp thông tin (bảng) mới, tương đương nút lệnh  New table  [image: image44.jpg]


  trên thanh công cụ Standard.
· Open Table ............................Mở một tập tin có định dạng được Mapinfo hỗ trợ, tương đương nút lệnh  Open  [image: image45.jpg]


  trên thanh công cụ Standard.
· Open Web service .................Mở một trang làm việc trên mạng.
· Open DBMS Connection................Mở một cơ sở dữ liệu nằm ngoài Mapinfo. Đây là phần tuỳ chọn khi cài đặt Mapinfo, lệnh này chỉ có khi ta cài đặt DBMS Support.
· Close Table ............................Đóng một lớp thông tin (bảng) đang mở. Khi đang mở nhiều bảng cùng một lúc, nếu thực hiện lệnh này sẽ có một hộp thoại hiện ra hỏi đóng bảng nào. Nếu bảng ta muốn đóng có chỉnh sửa thì Mapifo hiện ta một hộp thoại nữa hỏi ta có muốn lưu những chỉnh sửa hay không. Ta có thể lưu những thay đổi này bằng cách chọn bảng đó rồi chọn nút Save. Nếu không muốn lưu thì nhấn nút Discard.
· Close DBMS Connection...........Đóng một liên kết DBMS. Nếu một bảng cơ sở dữ liệu ngoài Mapinfo đang mở thì ta không thể dùng lệnh này.
· Close All.................................Đóng tất cả các lớp thông tin (bảng) đang mở.
· Save Table .............................Lưu những thay đổi trên bảng, tương đương nút lệnh  Save Table [image: image46.jpg]


  trên thanh công cụ Standard.
· Save Copy As ........................Lưu lớp thông tin (bảng) đang mở thành một lớp thông tin (bảng)  mới.
· Save Query.............................Lưu một query (kết quả của một phép truy vấn, tìm kiếm hay một phép chọn nào đó) thành một lớp thông tin (bảng) riêng.
· Save Workspace ....................Lưu workspace (không gian làm việc). Thực chất  workspace là những gì ta làm trên Mapinfo. Ví dụ như khi ta đang trình bày bản đồ mà dở dang chưa xong, ta có thể dùng lệnh lưu workspace để lưu lại tình trạng dở dang đó rồi đóng Mapinfo, tắt máy tính hoặc làm công việc khác. Khi khởi động lại Mapinfo và mở workspace đó ra, tất cả những gì ta làm dở dang sẽ được phục hồi lại nguyên trạng và ta có thể tiếp tục công việc mà không phải bắt đầu lại từ đầu. Workspace được sử dụng nhiều trong việc trình bày bản đồ cũng như kết quả phân tích dữ liệu. Workspace không làm thay đổi nội dung bảng Mapinfo.
· Save Windows As .................Lưu hình ảnh cửa sổ đang mở dưới dạng file hình ảnh. 
· Revert Table ..........................Huỷ bỏ những thay đổi đã thực hiện nhưng chưa ra lệnh lưu. 

· Page Setup .............................Định dạng trang in. 
· Print .......................................Thực hiện in bản đồ ra máy in, tương đương nút lệnh  Print Window  [image: image47.jpg]


  trên thanh công cụ Standard
· Recent files............................Danh sách các lớp thông tin (bảng) đang mở hoặc mới mở gần nhất. 

· Exit ........................................Thoát khỏi chương trình MapInfo, tương đương với tổ hợp phím <Alt>+<F4>
2. Menu EDIT 
Menu này cho phép thực hiện các lệnh liên quan đến việc chỉnh sửa các đối tượng hay dữ liệu cũng như xem thông tin.
· Undo ......................................Loại bỏ lệnh trước đó, tương đương nút lệnh  Undo  [image: image48.jpg]


  trên thanh công cụ Standard. Lệnh Undo này chỉ hiện ra khi ta vừa thực hiện một thay đổi nào đó trên bản đồ. Lệnh này hiện chung với tên lệnh vừa được thực hiện giúp ta nhớ lại mình vừa làm gì. Ví dụ nếu ta vẽ thêm (Add) một đối tượng vào bản đồ thì lệnh hiện ra sẽ là Undo Add. Khi đã chọn lệnh này thì lệnh Undo sẽ chuyển thành Redo (làm lại)
· Cut .........................................Cắt bỏ đối tượng đã chọn, tương đương nút lệnh  Cut  [image: image49.jpg]


  trên thanh công cụ Standard. Đối với dữ liệu, lệnh này xoá đi (các) hàng được chọn. Đối với phần bản đồ, ta có thể xoá một hay nhiều đối tượng sau khi chọn chúng. Phần bị xoá được đưa vào bộ nhớ tạm (clipboard) chứ chưa bị xoá hoàn toàn. Khi xoá một đối tượng đồ hoạ trên bản đồ thì hàng tương ứng trên bảng dữ liệu cũng bị xoá và ngược lại. Hàng bị xoá đổi thành màu xám và không còn dữ liệu.
· Copy/Copy Map Window.....................................Một trong hai lệnh này hiển thị tuỳ theo cửa sổ nào đang được mở hay đang được kích hoạt (nếu có nhiều cửa sổ đang mở), tương đương nút lệnh  Copy  [image: image50.jpg]


  trên thanh công cụ Standard. Nếu cửa sổ dữ liệu đang được mở và có bản ghi được chọn thì lệnh Copy hiện lên. Nếu cửa sổ bản đồ đang được kích hoạt thì lệnh Copy Map Window hiện lên. Phối hợp hai lệnh Copy Map Window và Paste sẽ cho kết quả tương tự lệnh CloneView trên menu Map.
· Paste .......................................Dán/chuyển đối tượng đã cắt/sao chép lên bảng dữ liệu hay bản đồ, tương đương nút lệnh Paste  [image: image51.jpg]


  trên thanh công cụ Standard.
· Clear ......................................Xoá đối tượng đồ hoạ hay bảng ghi đang chọn. Lệnh này không đưa thông tin bị xoá vào bộ nhớ tạm (mất hẳn).
· Clear Map Object Only .........Đối với một bảng vừa có đối tượng đồ hoạ (bản đồ) vừa có dữ liệu, lệnh này chỉ xoá các đối tượng đồ hoạ nhưng giữ lại phần dữ liệu. 
· Reshape .................................Chỉnh sửa hình dạng đối tượng, tương đương nút lệnh Reshape  [image: image52.jpg]


  trên thanh công cụ Drawing. Đây là lệnh dùng để chỉnh sửa hình dạng các đối tượng đồ họa bằng cách chỉnh sửa các nốt của chúng. Chí có ý nghĩa trên đường và vùng, không có tác dụng trên điểm. Lệnh này chỉ hiện rõ khi nào đối tượng được chọn thuộc một lớp đang ở chế độ chỉnh sửa. Khi chọn đối tượng đó rồi chọn nút này, các nốt của đối tượng đó hiện lên, ta có thể di chuyển các nốt cũng như thêm/bớt các nốt để thay đổi hình dạng của đối tượng.
· New Row................................Thêm một bản ghi mới vào lớp thông tin đang biên tập. Lệnh này chỉ hiện rõ khi khi nào cửa sổ dữ liệu được kích hoạt. Hàng mới sẽ được chèn vào cuối bảng dữ liệu.
· Get Infor ................................Hiển thị hộp thông tin địa lý về đối tượng đã chọn,  tương đương nút lệnh Info [image: image53.jpg]


  trên thanh công cụ Main. Lệnh này được sử dụng bằng cách  chọn nó rồi nhấp chuột lên đối tượng đồ hoạ trên cửa sổ bản đồ, các thông tin trong bảng dữ liệu của đối tượng đó sẽ được hiển thị trong hộp thoại Info tool.
3. Menu TOOLS
Menu tools cho phép thiết lập chế độ khởi động và chạy các ứng dụng của MapBasic, các lệnh chuyển đổi định dạng bản đồ số cũng như một số lệnh liên quan đến các thông tin trên internet hay các địa chỉ web.

· Crytal Reports......................Mở/tạo Báo cáo Crystal về thông tin trong một bảng Mapinfo. Đây là một phần rất lớn trong vấn đề quản lý cơ sở dữ liệu mà tài liệu này không thể đề cập. Crytal Reports nó có tài liệu hướng dẫn sử dụng riêng của nó. 

· Run MapBasic Program......................Chạy một chương trình MapBasic, tương đương nút lệnh Program [image: image54.jpg]


 trên thanh công cụ Tools. MapBasic là một phần mềm cho phép ta lập trình tạo thêm chức năng cho Mapinfo ngoài những chức năng đã có sẵn của chương trình chính.
· Tool Manager................................Quản lý các chương trình MapBasic. Lệnh này cho phép điều chỉnh chế độ khởi động của những chương trình MapBasic và có thể đăng ký thêm ứng dụng MapBasic.
4. Menu OBJECT 
Menu Objects gồm các lệnh chỉnh sửa trên cửa sổ bản đồ :
· Set Taget ................................Thiết lập “mục tiêu”. Một hay nhiều đối tượng có thể được biến thành mục tiêu và lệnh tiếp theo sau đó sẽ  tác dụng lên các mục tiêu. Điểm và ký tự không thể được thiết lập làm mục tiêu.
· Clear Taget ............................Huỷ thiết lập mục tiêu. Lệnh này sẽ trả đối tượng đang là mục tiêu sẽ trở về trạng thái bình thường.
· Combine ................................Gộp đối tượng. Ta có thể chọn hai hay nhiều đối tượng và dùng lệnh này để nhập chúng thành một đối tượng mới.
· Disaggregate.............................tách đối tượng. Lệnh này tách các đối tượng có nhiều thành phần ra thành nhiều phần đơn lẻ.
· Buffer .....................................Tạo vùng đệm cho một hay nhiều đối tượng đang được chọn. Vùng đệm này có bán kính do ta xác định.
· Convex Hull..............................Tạo ra một đa giác lồi chạy quanh các nốt ngoài cùng của những đối tượng được chọn. Lệnh này chỉ có tác dụng khi nào các đối tượng được chọn chứa ít nhất 3 nốt không thẳng hàng.
· Enclose.......................................Tạo ra các vùng từ các đường cắt nhau khép kín.
· Voronoi..................................Là lệnh chia một khu vực ra thành các vùng. Lệnh này lấy đầu vào (input) là các điểm và đầu ra (output) là các vùng, mỗi vùng chỉ chứa 1 điểm. 
· Split .......................................Cắt một hay nhiều đối tượng bằng một hay nhiều đối tượng khác. Muốn cắt một hay nhiều đối tượng thì (các) đối tượng đó phải được thiết lập là mục tiêu.
· Erase...........................................Xoá một phần (hay toàn bộ) một hay nhiều đối tượng. Phần bị xoá là phần chung với một hay nhiều đối tượng cắt. Cách thực hiện tương tự lệnh Split.
· Erase Outside .........................Xoá phần không chung (nằm ngoài) của một hay nhiều đối tượng. Phần bị xoá là phần không chung với (các) đối tượng cắt. Cách thực hiện tương tự lệnh Split.
· Overlay Node ........................Tạo ra điểm tại vị trí các đối tượng giao nhau. 
Trong các lệnh Split, Erase, Erase Outside  đối tượng cắt phải là đối tượng vùng.

· Overlay Nodes................................Tạo điểm chung (nốt) giữa một hay nhiều đối tượng được thiết lập là mục tiêu với một hay nhiều đối tượng được chọn. Nốt được tạo thành ở trên  (các) đối tượng mục tiêu.
· Check Regions..............................Lệnh này giúp kiểm tra lỗi các lớp kiểu vùng sau khi số hoá.

· Clean.............................................Làm sạch vùng. Lệnh Clean cho phép ta nhanh chóng sữa lỗi các bảng kiểu vùng. Ta có một số tùy chọn khi thực hiện lệnh này như xoá các vùng chờm lên nhau, xoá các chổ hở giữa các vùng cạnh nhau; các vùng tự cắt nhau cũng sẽ tự động được sữa lỗi.

· Snap/Thin...............................Lệnh này tự động tinh chỉnh các đối tượng sau khi số hoá. Nó cho phép nhập hai nốt sát nhau trên hai hay nhiều đối tượng khác nhau lại chung một vị trí, loại bỏ nốt ở giữa trong 3 nốt gần như thẳng hàng, xoá bỏ các vùng có diện tích nhỏ hơn diện tích chỉ định.

· Smooth ...................................Lệnh bo tròn góc của các đối tượng kiểu đường. Lệnh này nắn tròn các đoạn của đường thành các cung (arc) tiếp tuyến với góc nhỏ giữa hai đoạn của đường. Đây chỉ là lệnh giúp hiển thị đối tượng kiểu đường sao cho chúng trông “tròn trịa” hơn mà thôi.
· UnSmooth...............................Loại bỏ “sự bo tròn” các đối tượng đã chọn. 
· Convert to Region .................Chuyển đối tượng đường khép kín thành đối tượng vùng.
· Convert to Polyline ................Chuyển đối tượng vùng thành đối tượng đường khép kín.
5. Menu QUERY 
Menu này bao gồm các lệnh liên quan đến việc chọn, tìm thông tin

· Select......................................Chọn đối tượng/bảng ghi trong một bảng. Khi dùng lệnh này phải đưa ra điều kiện chọn ở dạng biểu thức (expression) để Mapinfo thực hiện phép chọn.
· SQL Select .............................Chọn bằng SQL, cũng là lệnh chọn nhưng SQL Select  có cấu trúc lệnh phức tạp hơn đồng thời nó cho phép ta chọn dữ liệu mạnh hơn so với Select. SQL là chữ viết tắt của Structured Query Language (Ngôn ngữ Truy vấn có Cấu trúc).
· Select All From.....................Chọn tất cả các đối tượng trong lớp thông tin đang mở. 
· Invert Selection........................Đảo ngược phép chọn, tức khử chọn những đối tượng đang được chọn và chọn những đối tượng trước đó không được chọn, tương đương nút lệnh Invert   [image: image55.jpg]


  trên thanh công cụ Main
· Unselect All............................khử chọn tất cả những đối tượng/bản ghi đang được chọn.
· Find ........................................Lệnh này tìm kiếm một đối tượng nào đó trên bản đồ và đánh dấu nó. Ta chỉ có thể dùng lệnh này nếu bảng được đánh dấu là Indexed ở trường cần tìm.
· Find Selection ........................Tìm kiếm các đối tượng đang chọn vào cửa sổ hiện thời trên màn hình. 

· Calculate Statistics ................Hiển thị cửa sổ thông tin tính toán thống kê. Chỉ có tác dụng khi nào bảng được chọn chứa các trường kiểu số
6. Menu TABLE 
Menu này bao gồm các lệnh liên quan đến dữ liệu của các lớp bản đồ, các dữ liệu ngoài Mapinfo và một số lệnh về ảnh quét đã đăng ký vào Mapinfo.

· Update Column .....................Cập nhập cột. Lệnh này cập nhập thông tin vào bảng dữ liệu của Mapinfo bằng cách gõ biểu thức.
· Append Row to Table ...........Ghép nối các hàng của một bảng hay một dữ liệu khác có cùng cấu trúc vào bảng được chọn.
· Geocode.....................Mã địa hoá. Lệnh này hiển thị thông tin của một bảng dữ liệu lên bản đồ.
· Creat Point .............................Lệnh này vẽ các điểm lên bản đồ theo số liệu từ hai cột toạ độ có trong bảng cần được vẽ điểm.
· Combine Object using Column....................Đây là lệnh gộp các đối tượng lại theo dữ liệu trong một cột. Ta phải chỉ định cột nào được sử dụng để gộp đối tượng. Những đối tượng nào có chung giá trị trong cột được chỉ định sẽ bị gộp lại thành một đối tượng.
· Import.....................................Nhập. Lệnh này cho phép nhập các tập tin có định dạng khác vào Mapinfo  các dữ liệu địa lý trong các khuôn dạng (format) trao đổi đồ hoạ và với các hệ thống. Bao gồm Mapinfo Interchange (*.mif), AutoCAD DXF (*.dxf), Mapinfo DOS MBI (*.mbi), Mapinfo DOS MMI (*.mmi), Mapinfo DOS Image (*.img).
· Export.....................................Xuất. Lệnh này xuất dữ liệu trong bảng Mapinfo sang một định dạng khác. Các định dạng hỗ trợ là Mapinfo Interchange (*.mif), Delimited ASCII (*.txt), AutoCADDXF (*.dxf), và dBASE DBF (*.dbf).
· Maintenance ..........................Chỉnh sửa cấu trúc bảng dữ liệu của Mapinfo như thêm trường, thay đổi thuộc tính, kích thướt trường…Ngoài ra còn có một số lệnh khác như xoá bảng, “đóng gói” bảng, đổi tên bảng, Menu này cũng có thêm những lệnh liên quan đến các bảng DBMS.
· Raster .....................................điều chỉnh ảnh quét (ảnh raster) trong Mapinfo. Ta có thể điều chỉnh độ tương phản, độ sáng cũng như độ trong mờ (Translucency) của  ảnh quét đã được mở trong Mapinfo. Nó cũng cho phép thay đổi đăng ký tọa độ ảnh quét trong Mapinfo.
7. Menu OPTIONS 

Menu này gồm các lệnh định dạng đối tượng đồ hoạ trong Mapinfo, các lệnh hiển thị cửa sổ và các thanh công cụ và những thiết lập các tuỳ chọn của Mapinfo.
· Line Style ..............................Thay đổi cách thể hiện các đối tượng đường, tương đương với nút lệnh Line Style  [image: image56.jpg]


  trên thanh công cụ Drawing.
· Region Style ..........................Thay đổi cách thể hiện các đối tượng vùng, tương đương với nút lệnh Region Style  [image: image57.jpg]


  trên thanh công cụ Drawing.
· Symbol Style ..........................Thay đổi cách thể hiện các đối tượng điểm, tương đương với nút lệnh Symbol Style  [image: image58.jpg]


  trên thanh công cụ Drawing.
· Text Style ..............................Thay đổi cách thể hiện các đối tượng chữ, tương đương với nút lệnh Text Style  [image: image59.jpg]


  trên thanh công cụ Drawing.
· Toolbars .................................Bật/Tắt và điều chỉnh chế độ hiển thị các thanh công của Mapinfo. 
- Show Legend Window ..........Bật/Tắt cửa sổ ghi chú. 

- Show Statistics Window.........Bật/Tắt cửa sổ thông tin thống kê. 
- Show MapBasic Window.......Bật/Tắt cửa sổ câu lệnh của MapBasic, tương đương với nút lệnh Show/Hide MapBasic Window [image: image60.jpg]


 trên thanh công cụ Drawing.
· Hide Status Bar....................... Bật/Tắt thanh trạng thái ở dưới cửa sổ chính của Mapinfo.
· Custom Color .........................Tạo thêm màu theo ý muốn người dùng. Nếu đánh dấu chọn vào Save color thì màu tạo ra sẽ được lưu lại trên bảng màu của Mapinfo.
· Preferences .............................Điều chỉnh những thiết lập khác nhau theo ý muốn của người dùng Mapinfo, ví dụ như chọn thư mục lưu các tập tin bản đồ của Mapinfo, thư mục lưu các tập tin Workspace, chọn máy in, điều chỉnh cửa sổ bản đồ, cửa sổ chứ giải…
8. Menu MAP

Menu này bao gồm các lệnh sau :

· Layer Control .........................Kiểm soát lớp,  tương đương với nút lệnh Layer Control  [image: image61.jpg]


  trên thanh công cụ Main. Lệnh này dùng để điều chỉnh việc hiển thị và tính chất các lớp đang mở.
· Create 3D Map.......................Tạo bản đồ 3 chiều từ một tập tin Grid (lưới). Tập tin này được tạo ra từ lệnh Create Thematic Map.
· Create Prism Map...................Tạo bản đồ 3 chiều dạng lăng trụ (Prism) theo dữ liệu do ta chỉ định. Chỉ có những bảng kiểu vùng mới chạy được lệnh này.
· Create Thematic Map.............Tạo ra bản đồ chuyên đề. Lệnh này nói một cách nôm na là “tô màu” cho bản đồ theo các giá trị có trong trường dữ liệu của bản đồ hay các số liệu ngoài liên kết với bản đồ, đồng thời làm chú giải cho việc tô màu đó.
· Modify Thematic Map ...........Điều chỉnh bản đồ chủ đề được tạo thành trong lệnh trên. 
· Create Legend............................Làm chú giải cho bản đồ.
· Change View..........................Thay đổi tỷ lệ bản đồ xuất hiện trên màn hình. 
· Clone View.............................Tạo ra một cửa sổ bản đồ mới  giống như cửa sổ hiển thị đang mở. 
· Previous View ........................Quay trở lại chế độ hiển thị trứơc đó của cửa sổ bản đồ đang hiển thị. 
· View Entire Layer..................Thay đổi tỷ lệ của bản đồ để hiển thị hết nội dung của một hay tất cả các lớp bản đồ đang mở trong cửa sổ bản đồ được kích hoạt
· Clear Custom Lables..............Xoá các nhãn được tạo ra trước đó.
· Save Cosmetic Layer..............Lưu lại các thông tin nằm ở lớp trên cùng (lớp Cosmetic) thành một lớp mới hay lưu vào một lớp bản đồ đang mở. 
· Clear Cosmetic Objects..........Loại bỏ các thông tin nằm ở lớp trên cùng (lớp Cosmetic) của bản đồ.
· Set Clip Region ......................thiết lập vùng cắt, tương đương với nút lệnh Clip Region  [image: image62.jpg]


   trên thanh công cụ Main. Lệnh này cho phép ta chỉ hiển thị bản đồ trong giới hạn của vùng được chọn. Sau khi đã chọn vùng cắt ta có thể bật hay tắt chế độ này, đồng thời cũng có thể thay đổi vùng cắt nếu muốn.
· Clip Region on/off..................bật/tắt vùng cắt, là  On khi đã có vùng cắt và chưa bật lên, Off  khi vùng cắt đã được bật lên, tương đương với nút lệnh Clip Region On/Off  [image: image63.jpg]=}



 trên thanh công cụ Main.
· Digitizer Setup........................Cài đặt thiết bị số hoá. Thiết bị số hoá (Digitizer) hay bàn số hoá (Digitizing table) là một thiết bị được nối vào máy tính. Nó cho phép ta đưa bản đồ giấy vào thiết bị này và scan lại bản đồ đó. Quá trình scan lại bản đồ trên bàn số hoá đồng thời cũng được chuyển vào Mapinfo. Công việc này được gọi là số hoá bản đồ. Tuy nhiên, bàn số hoá là một thiết bị đắt tiền nên chỉ có những cơ quan chuyên dụng mới dùng mà thôi.
· Option.....................................Xác định một số tham số tùy chọn cho hệ thống MapInfo đang mở. Tại đây, ta có thể thay đổi đơn vị toạ độ, khoảng cách, diện tích,…cũng như chế độ cửa sổ bàn đồ phóng to, thu nhỏ…    
9. Menu WINDOW 
Menu này gồm các lệnh mở/điều chỉnh sự hiển thị  của các cửa sổ.
· New Browser Window...........Mở cửa sổ hiện thị dữ liệu dưới dạng bảng như Excel, tương đương nút lệnh New Browser [image: image64.jpg]


  trên thanh công cụ Standard. Cửa sổ mới này có thể là toàn bộ bảng dữ liệu hoặc một phần dữ liệu của một bảng, tuỳ thuộc vào phép chọn được thực hiện trước đó.
· New Map Window .................Mở cửa sổ hiện thị dữ liệu dưới dạng bản đồ, tương đương nút lệnh New Map  [image: image65.jpg]


  trên thanh công cụ Standard.
· New Graph Window...............Thực hiện lệnh vẽ biểu đồ/đồ thị, tương đương nút lệnh  New Graph  [image: image66.jpg]


  trên thanh công cụ Standard.
· New Layout Window .............Mở cửa sổ hiển thị dữ liệu dưới dạng biên tập để trình bày trước khi in ra máy, tương đương nút lệnh New Layout  [image: image67.jpg]


  trên thanh công cụ Standard.
· New Redistrict Window.........Mở cửa sổ thông tin phân nhóm, tương đương nút lệnh New Redistrict  [image: image68.jpg]


  trên thanh công cụ Standard. 
· Redraw Window.....................Vẽ lại màn hình sau khi có sự thay đổi. Lệnh này tương tự như lệnh làm tươi màn hình (refresh) của hệ điều hành nhưng chỉ tác động lên cửa sổ bản đồ mà thôi.
· Tile Window...........................Sắp xếp tất cả các cửa sổ đang mở sao cho chúng đều được hiển thị trên màn hình (các cửa sổ không che lấp nhau).
· Cascade Window....................Sắp xếp tất cả các cửa sổ đang mở sao cho tiêu đề của chúng có thế nhìn thấy được (các cửa sổ vẫn che lấp nhau).
· Arrange Icon...........................Sắp xếp các biểu tượng hệ thống vào màn hình hiện tại
· Phần dưới cùng của Menu Window liệt kê danh sách các cửa sổ đang được mở.

10. Menu HELP

Đây là phần trợ giúp của Mapinfo, như là Mapinfo Professional Help Topics khởi động phần giúp đỡ của Mapinfo hay Mapinfo on the Web khởi động liên kết vào trang web của Mapinfo hoặc About This Mapinfo Product giới thiệu phiên bản cũng như số đăng ký bản quyền và các thông tin liên quan đến phần mềm Mapinfo đang được sử dụng…
CÁC HỘP CÔNG CỤ CỦA MAPINFO
1. Thanh công cụ Standard
Thanh công cụ này bao gồm các nút lệnh sau 


.  
1. New Table Button : tạo bảng mới; tương đương lệnh File -> New Table.
2. Open Table Button : mở một bảng; tương đương lệnh File -> Open Table.
3. Open Workspace Button : mở một workspace
4. Save Table Button  : lưu một bảng; tương đương lệnh File -> Save Table.
5. Save Workspace Button  : lưu một workspace; tương đương lệnh File -> Save Workspace.
6. Save Window Button : lưu cửa sổ làm việc theo các dạng hình ảnh; tương đương lệnh File -> Save Window As.

7. Print Window Button : in một cửa sổ đang được kích hoạt, tương đương lệnh File -> Print.
8. Cut Button : cắt một hay nhiều đối tượng hay bản ghi được chọn; tương đương lệnh Edit -> Cut.

9. Copy Button : sao chép một hay nhiều đối tượng hay bản ghi được chọn, tương đương lệnh Edit -> Copy.
10.  Paste Button : dán một hay nhiều đối tượng hay bản ghi đã được sao chép trước đó, tương đương lệnh Edit -> Paste

11. Undo Button : huỷ bỏ lệnh vừa thực hiện; tương đương lệnh Edit -> Undo.
12. New Brower Button : mở một cửa sổ dữ liệu mới; tương đương lệnh Window -> New Brower Window.

13. New Mapper Button : mở một cửa sổ bản đồ mới; tương đương lệnh Window -> New Mapper Window.

14. New Grapher Button : vẽ biểu đồ/đồ thị; tương đương lệnh Window -> New Grapher Window.

15. New Layout Button : mở một cửa sổ trình bày mới; tương đương lệnh Window -> New Layout Window.

16. New Redistricter Button : thực hiện lệnh phân chia nhóm; tương đương lệnh Window -> New Redistricter Window.

17. Help Button : giúp đỡ, khi nhắp chuột vào nút lệnh này, con trỏ chuột biến thành hình con trỏ và dấu chấm hỏi. Nhấp chuột lên nội dung nào trong Mapinfo sẽ hiển thị nội dung giúp đỡ liên quan đến phần đó.
2. Thanh công cụ Main
Thanh công chính này có các nút lệnh sau: 

· 4. Polygon Select Button : Là công cụ chọn bằng cách vẽ một vùng, những đối tượng có trọng tâm nằm trong vùng đó sẽ được chọn.

· 5. Boundary Select Button : Là công cụ chọn bằng cách nhắp chuột lên một vùng trên một lớp bản đồ, những đối tượng có trọng tâm nằm trong vùng đó nhưng thuộc một lớp khác sẽ được chọn.

· 6. Unselect All Button : Khử chọn tất cả những đối tượng/bản ghi đang được chọn.
· 7. Invert Selection Button : Đảo ngược phép chọn, có nghĩa là khử chọn những đối tượng đang được chọn và chọn những đối tượng không được chọn trong một bảng.

· 8. Graph Select Button : Chọn một giá trị trên biểu đồ. Đối với những biểu đồ được tạo ra không dựa vào những giá trị trong bảng dữ liệu thì nút này không hoạt động. 
· 9. Zoom-in Button : Phóng to bản đồ bằng cách nhấp chuột hoặc rê chuột chọn một vùng. Mỗi lần nhắp chuột bản đồ sẽ phóng to ra gấp đôi.

· 10. Zoom-out Button : Tương tự nút Zoom-in nhưng là nút thu nhỏ.

· 11. Change View Button : Thay đổi tỷ lệ và vị trí bản đồ bằng cách nạp giá trị.

· 12. Grabber Button : Nút công cụ này dùng để di chuyển bản đồ. Muốn di chuyển bản đồ, ta nhắp chuột chọn nút này, di chuyển chuột lại cửa sổ bản đồ, rê chuột thì bản đồ sẽ di chuyển.

· 13. Info Tool Button : Xem thông tin của một đối tượng trên bản đồ bằng cách chọn nút lệnh này rồi nhắp chuột vào đối tượng đó trên cửa sổ bản đồ.

· 14. Hot Link Button : Mở một tập tin định dạng khác trên máy tính hay một địa chỉ trên mạng. 

· 15. Lable Button : Nút này dùng để dán nhãn thủ công các đối tượng trên cửa sổ bản đồ bằng dữ liệu từ bảng.

· 16. Drag Map Window Button : Kéo một cửa sổ bản đồ sang một phần mềm khác. Muốn thực hiện điều này ta phải mở 2 cửa sổ bản đồ đồng thời, cửa sổ Mapinfo và cửa sổ ứng dụng kia. Word chẳng hạn, rồi chọn nút này, để con trỏ chuột trên cửa sổ bản đồ, rê con chuột sang cửa sổ kia. Bản đồ sẽ được chèn vào vị trí dấu nhắc trong phần mềm kia.
· 17. Layer Control Button : Tương tự lệnh Map -> Layer Cotrol , mở hộp thoại kiểm soát các lớp làm việc.
· 18. Ruler Button : Đo khoảng cách trên bản đồ bằng cách di chuyển chuột và nhắp chuột. Khoảng cách được tính là độ dài các đoạn thẳng nối từ vị trí nhắp chuột này sang vị trí nhắp chuột khác. 
· 19. Show/Hide Legend Button : Bật/Tắt cửa sổ chú giải.

· 20. Show/Hide Statistics Button : Bật/Tắt cửa sổ thống kê, cửa sổ này thể hiện giá trị tổng (Sum) và trung bình (Average) trong các trường kiểu số của các đối tượng đang chọn.
· 21. Set Target District Button : Thiêt lập nhóm chứa đối tượng được chọn trên cửa sổ bản đồ thành một nhóm mục tiêu trong cửa sổ District Browser.

· 22. Assign Select Objects Button : gán đối tượng được chọn vào nhóm mục tiêu.

· 23. Clip Region On/Off  Button : Bật/Tắt chế độ cắt vùng.

· 24. Set Clip Region Button : Thiết lập vùng cắt.

3. Thanh công cụ Drawing

Để sử dụng được các nút lệnh này, phải có một lớp bản đồ đang ở chế độ chỉnh sửa. Các nút lệnh này chỉ có tác dụng trên cửa sổ bản đồ. Thanh công cụ này gồm 16 nút lệnh  với ý nghĩa như sau:

· 1. Symbol Button : vẽ một điểm trên bản đồ. Cách vẽ :

chọn nút này rồi nhắp chuột lên vị trí muốn chấm biểu tượng.

· 2. Line Button : là nút lệnh vẽ một đường thẳng. Cách 

làm : chọn nút công cụ này, nhắp chuột trái tại vị trí bắt đầu và 

rê chuột đến vị trí kết thúc rồi thả phím chuột trái ra.

· 3. Polyline Button : là nút lệnh vẽ đường gấp khúc. Cách vẽ : chọn nút lệnh này, di chuyển chuột về cửa sổ bản đồ, con trỏ chuột biến thành hình dấu cộng, nhắp chuột tại vị trí muốn bắt đầu vẽ, di chuyển chuột rồi lại nhắp chuột để tao ra một đoạn, thực hiện tương tự cho đến khi vẽ hết đường cần vẽ. Nhắp chuột đúp tại vị trí kết thúc để chấm dứt đường vẽ hay nhắpchuột một lần tại vị trí kết thúc rồi nhấn phím <Esc>.
· 4. Arc Button : nút lệnh này cho phép ta vẽ một cung. Cách vẽ tương tự như vẽ một đường thẳng.
· 5. Polygon Button : nút lệnh này cho phép ta vẽ một hình đa giác (tức một vùng). Cách vẽ tương tự như vẽ một đường gấp khúc nhưng khi kết thúc đường thì nốt của đoạn cuối cũng sẽ nối vào nốt đầu tiên của đoạn đầu tiên để khép kín đường vẽ và tạo ra một vùng.

· 6. Ellipse Button : vẽ một hình ellipse. Giữ phím <Shift> khi rê chuột sẽ tạo ra một hình tròn. Cách vẽ tương tự như cách vẽ một đường thẳng.
· 7. Rectangle Button : vẽ hình chữ nhật. Giữ phím <Shift> khi rê chuột sẽ tạo ra một hình vuông. Cách vẽ tương tự như cách vẽ một đường thẳng.

· 8. Rounded Rectangle Button : vẽ hình chữ nhật có góc bo tròn. Giữ phím <Shift> khi rê chuột sẽ tạo ra một hình vuông. Cách vẽ tương tự như cách vẽ một đường thẳng.

· 9. Text Button : gõ chữ vào cửa sổ bản đồ. Nút lệnh này tạo giúp tạo ra đối tượng kiểu ký tự. Cách gõ :  nhắp chuột chọn công cụ này rồi di chuyển chuột vào cửa sổ bản đồ, nhắp chuột tại vị trí muốn gõ chữ, gõ nội dung cần thiết, sau khi gõ xong, di chuyển chuột về thanh công cụ Main nhắp chuột vào công cụ chọn (Select Button ), lệnh gõ chữ sẽ kết thúc.

· 10. Fram Button : tạo một khung để chứa thông tin cửa sổ trình bày. Khi sử dụng nút lệnh này để vẽ một khung, Mapinfo sẽ hiển thị hộp thoại hỏi ta muốn chèn nội dung nào vào khung đó. Nội dung có thể được chèn vào là một trong những cửa sổ đang được mở trong Mapinfo. Cửa sổ được chèn vào khung có thể là một bản đồ, biểu đồ, cửa sổ dữ liệu, chú giải bản đồ, cửa sổ thông tin, cửa sổ thống kê hoặc có thể là một khung rỗng…
· 11. Reshape Button : chỉnh sửa hình dạng của đối tượng sau khi vẽ xong. Nút lệnh này chỉ sử dụng được khi nào có một lớp bản đồ đang ở chế độ chỉnh sửa và một đối tượng trong đó đã được chọn.

· 12. Add Node Button : thêm một nốt vào đối tượng kiểu đường hay vùng.

· 13. Symbol Style Button : chọn/chỉnh kiểu biểu tượng. Nút lệnh này là lệnh tắt của  Options -> Symbol Style.
· 14. Line Style Button  : chọn/chỉnh kiểu đường. Tương tự lệnh Options -> Line Style.
· 15. Region Style Button  : chọn/chỉnh kiểu vùng. Tương tự lệnh Options -> Region Style.
· 16. Text Style Button  : chọn/chỉnh kiểu chữ. Tương tự lệnh Options -> Text Style. Có tác dụng với cửa sổ bản đồ và cửa sổ Browser.
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Restore Previous Session: Cho phép bạn mở lớp thông tin mà bạn đã mở lần cuối cùng trong MapInfo. 


Open Last Used Workspace: Cho phép bạn mở tập tin quản lý chung .wor mà bạn đã mở lần cuối cùng trong MapInfo (ví dụ ở hình bên trái thì tập tin Dia_hinh.wor là tập tin được mở lần cuối trong MapInfo). 


Open a Workspace: Cho phép bạn mở một file quản lý chung mới có phần mở rộng là .wor 


Open a Table: Cho phép bạn mở một lớp dữ liệu mới là những file có phần mở rộng .tab





    - 	Nếu lớp dữ liệu có chứa dữ liệu không gian (Spatial data), tức các đối tượng địa lý với toạ độ tương ứng được lưu trữ dưới dạng số (digital format), trên màn hình sẽ xuất hiện một cửa sổ bản đồ (map window) với các đối tượng của lớp dữ liệu (có thể chỉ một số các đối tượng này) như hình bên cạnh.
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▪ 	Chúng ta có thể chọn một (hay nhiều) đối tượng từ danh sách các đốitượng trong cửa sổ dữ liệu (Browse Window). Một lớp dữ liệu có đối tượng địa lý luôn đi kèm danh sách các đối tượng này và để xem chúng, chúng ta vào Window -> New Browse Window (hay nhấn phím F2), sau đó chọn tên lớpdữ liệu cần hiển thị trong cửa sổ Browse Table và nhấn OK như hình bên.











�





�





�





Menu chính





Cửa sổ Dữ liệu





Cửa sổ Bản đồ





Thanh công cụ Standard





Thanh trạng thái





Thanh công cụ Tools





Thanh công cụ Main





Thanh công cụ Drawing





▪ 	Để xem và thay đổi các thuộc tính (thấy dược, sửa đổi được, được chọn và tự động ghi chú cho các đối tượng) của một lớp dữ liệu sau khi đã được mở trong MapInfo, chúng ta vào Map -> Layer Control (khi đang làm việc trên một cửa sổ bản đồ) hay nhấn chuột vào biểu tượng Layer Control  �  trong hộp công cụ hoặc nhấn tổ hợp phím Crtl-L. Khi đó xuất hiện cửa sổ Layer Control, muốn gán thuộc tính nào cho lớp dữ liệu chúng ta 
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Cho phép bật hay tắt các lớp dữ liệu





Cho phép bật hay tắt thuộc tính sửa đổi được 





Cho phép bật hay tắt sự lựa chọn đối tượng 














Cho phép bật hay tắt nhãn của đối tượng 





▪ 	Khi mở một hay nhiều lớp dữ liệu có các đối tượng địa lý, mỗi lớp dữ liệu này trong cửa sổ bản đồ là là một "Layer" hay còn gọi là một lớp bản đồ. Trong cửa sổ bản đồ, ngoài các lớp bản đồ được mở với File -> Open Table, luôn luôn có một lớp bản đồ tạm thời có tên là "Cosmetic Layer". Cosmetic Layer là một lớp trong suốt và luôn nằm ở vị trí trên cùng của "chồng" các lớp bản đồ. Trong quá trình xử lý, chúng ta (hoặc MapInfo) có thể sẽ ghi thông tin trên lớp bản đồ này. Để lưu lại những thông tin trên lớp Cosmetic Layer, chúng ta vào Map -> Save Cosmetic Objects và nhập tên một lớp dữ liệu mới. Chúng ta cũng có thể xoá các thông tin trên lớp Cosmetic Layer bằng cách vào Map -> Clear Cosmetic Layer. 
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 ▪ 	Thông thường dùng file Workspace để lưu lại môi trường đang làm việc mà chúng ta muốn tiếp tục về sau như số hoá bản đồ hay dùng để lưu các bản đồ chuyên đề phục vụ cho việc biên tập các bản đồ trên trang in. File Workspace là một file được lưu trữ dưới dạng text, vì vậy chúng ta có thể dùng các phần mềm xử lý văn bản thông dụng đều có thể đọc và sửa chữa file .wor này.
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	-	Vào File -> Open Table, chọn Raster Image trong thư mục List Files of Type, kế tiếp chọn thư mục và tập tin chứa hình ảnh quét của bản đồ. Nhấn OK, chọn Register trong cửa sổ xuất hiện để đăng nhập toạ độ địa lý tương ứng với các mục cần khai báo như hình bên. 
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▪	 Để sử dụng tập tin ảnh này như là bản đồ giấy, ta phải khai báo đăng nhập tọa độ của nó và có thể sử dụng như bản đồ nền trong quá trình số hoá. 





	-	Nhấn chuột vào Projection để tiến hành khai báo thông số của hệ quy chiếu như đã đề cập ở trên phần trên, tùy theo loại bản đồ gì mà ta chọn hệ quy chiếu cho phù hợp như hình dưới. 











▪		Mỗi khi muốn khai báo một điểm mới, phải xác định rõ toạ độ cửa điểm đó trên bản đồ giấy và dịch chuyển ảnh quét sao cho vị trí của điểm đó nằm ở trong khung nhìn. Nhấn chuột vào mục New, biểu tượng con trỏ sẽ thay đổi từ hình dạng mũi tên sang hình dạng chữ thập. Di chuyển chuột đến đúng chính xác vị trí tương ứng của điểm muốn định vị và nhấn chuột, sẽ xuất hiện cửa sổ Add Control Point (hình bên).
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Khai báo toạ độ các điểm





▪	Sau khi đã đăng nhập ảnh, muốn thay đổi khai báo toạ độ vị trí các điểm, vào Table > Raster -> Modify Image Registration, sẽ xuất hiện cửa sổ Image Registration để chúng ta thêm bớt hay sửa đổi vị trí điểm. 
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▪	Map -> Save cosmetic objects  mà có một lớp khác đang mở (trong trường hợp này là Text_Dis, Boundary_Com, Boundary), hộp thoại Save cosmetic objects  mở ra. 





▪	Nếu nhấn nút thả xuống ta sẽ thấy danh sách các lớp đang mở. Nếu ta chọn Text_Dis, thì các đường giao thông ta mới số hóa sẽ nhập vào chung với lớp Text_Dis. Cho nên ta phải chọn New để lưu thành một lớp mới. Chế độ mặc định trong Mapinfo khi chọn Save cosmetic objects  luôn luôn là  <New>.
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File Thixa.tab (file ta cập nhập dữ liệu)





�





	        		File Huyenhc.tab (file ta lấy dữ liệu)
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Ví dụ: Tính diện tích các đối tượng địa lý (TP và huyện) của tỉnh Kon Tum, chúng ta thêm cột "Dientich" vào Huyenhc.tab và sử dụng hàm Area(). Vào Update Columns, khai báo như hình bên, sau khi nhấn OK dữ liệu sẽ tự động cập nhật vào cột Dientich, có thể vào Window -> New Browser Window để xem kết quả. 
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	    Cập nhập số liệu vào Column													
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					    Liên kết Join trong Update Column





Calculate: Sum 


Trường hợp này thì chúng ta chọn tên cột liên kết giữa hai lớp dữ liệu trong cửa sổ Joint là Ma_huyen (cũng với 2 file như trên). Việc tính diện tích cho thị xã kon tum thông qua việc tính tổng diện tích của các xã phường trong thị xã, tức là máy sẽ cộng tất cả số liệu cột Dien_tich trong file Dis_pol.tab thông qua cột Ma_huyen, sau đó cập nhật cho diện tích tổng này ở cột Dien_tich  trong file Thixa.tab. 
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 File Dis_pol.tab
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Cập nhập số liệu vào Column
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     Liên kết Join trong Update Column
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Kết quả ta có được
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Kết quả 
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Khai báo trong SQL Select





File Dia_ly





        File Tong_hop





Kết quả





Kết quả sẽ là một lớp dữ liệu mới với tất cả các đối tượng địa lý và các cột số liệu về dân số như bảng dưới đây. Muốn sử dụng lớp dữ liệu này chúng ta phải lưu vào đĩa với File -> Save As. 





Để không thể hiện một hay nhiều vùng (field): trong khung Column in Browser chọn các vùng này, sử dụng phím Shift hay Control khi chọn nhiều vùng, sau đó nhấn chuột vào mục Remove để loại chúng ra khỏi danh sách các vùng sẽ được thể hiện.


Để thay đổi tiêu đề một vùng, chúng ta đánh dấu vùng đó trong khung Columns in Browser, sau đó nhập tên mới vào vùng Name trong khung Edit Browser Column. 


Ví dụ: đổi tên cột vùng "Don_vi_hanh_chinh " thành tên "DVHC.





..". 
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    Sử dụng Pick Field trong New Browser Windows








- Trong cột Destination sẽ liệt kê tất cả tên cột của lớp dữ liệu.


-  Trong cột Method, có thể chọn 1 trong 4 kiểu liệt kê trong khung Aggregation Method bên dưới: Blank (để trống); Sum (tổng giá trị của các đối tượng được chọn); Value (một giá trị hằng) hay Average (trung bình cộng giá trị của các đối tượng được chọn). 
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-  Nếu chọn No Data thì giá trị các cột trên là 0. 


-  Nhấn OK sẽ xuất hiện một đối tượng mới. 
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Đối tượng được xử lý





Đối tượng chuẩn
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Đối tượng mới
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Đối tượng được xử lý





Đối tượng chuẩn





Đối tượng mới
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Đối tượng được xử lý





Đối tượng chuẩn





Đối tượng mới
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Chức năng này kết hợp các đối tượng có cùng một giá trị để hình thành một đối tượng mới với kích thước lớn hơn với các số liệu được được kết hợp lại; có thể xem chức năng này là ngược lại của chức năng chia cắt (Split) và sử dụng chức năng này để kết hợp lại những phần tử của các đối tượng đã bị chia cắt. 


Vào Table -> Combine Object Using Column và khai báo cột có các đối tượng có cùng giá trị muốn kết hợp lại trong mục Group objects by column trong cửa sổ Combine Object Using Column. 


Nếu chúng ta chọn lớp dữ liệu để lưu kết quả là cùng lớp dữ liệu được xử lý thì kết quả (các đối tượng mới) sẽ được ghi tiếp thêm ở phía sau trong lớp dữ này. 
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Để thay đổi thứ tự các lớp dữ liệu, chọn từng lớp dữ liệu và sử dụng button "Up" hay "Down" trong khung Reoder để đưa lớp dữ liệu đó lên hoặc xuống. Điều này cũng rất quan trọng vì có thể lớp dữ liệu bạn mỡ có thể nằm ở dưới một lớp vùng nào đó và không thể hiện được, trong trường hợp này bạn phải di chuyển lớp này lên phía trên. Trong ví dụ trên lớp “Song_suoi” bi lớp “Giao_thong” che khuất.
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+  Trường hợp chúng ta muốn lớp dữ liệu đang xét luôn thể hiện trong cửa sổ bản đồ thì ta sẽ để mặc định. Ngược lại, chúng ta click vào ô trống ở đầu hàng chữ Display with Zoom Range và chọn độ zoom tối thiểu và tối đa trong 2 khung bên dưới. 


+ Sau khi cài Zoom Layering, nếu mức độ zoom của cửa sổ bản đồ phép thể hiện lớp dữ liệu thì trong cửa sổ Layer Control lớp dữ liệu được đánh dấu màu đen. 
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Trong khung Visibility, chúng ta có thể chọn: 


- On: cho phép luôn nhìn thấy. 


- Off: không cho phép nhìn thấy. 


- Display with range: cho phép nhìn thấy trong khoảng phóng đại được xét bởi Min Zoom và Max Zoom ở bên dưới.


 - Cũng trong khung này chúng ta xét cho phép các ghi chú này được lặp lại (duplicate) và được chồng nhau (overlay) hay không cũng như số ghi chú tối đa cho các đối tượng của lớp dữ liệu (xét từ trên xuống, nếu muốn ghi 
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- Kế tiếp, trong khung Styles chúng ta có thể chọn kiểu dạng của văn bản (font, cỡ và màu chữ). Đối với Label Lines (đường nối từ trung tâm của đối tượng đến ghi chú), chúng ta có thể chọn None (không), Line (đường nối) hay Arrow (đường nối với mũi tên). Việc định dạng kiểu đường cùng với màu sắc và độ rộng được thực hiện bằng cách nhấn chuột vào khung định dạng. 
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Cửa sổ Create Thematic Map – Step 3 of 3 xuất hiện với kết quả sơ bộ của việc thể hiện các cấp đối tượng được nhìn thấy trong khung Preview và chúng ta có thể thay đổi về dạng thức thể hiện (Style) cũng như các chú thích (Legend) bằng cách thay đổi cách sắp thứ tự các cấp tùy theo giá trị của cột được chọn là tăng (Ascending) hay giảm dần 


Để thay về dạng thức, chúng ta click vào khung Styles, cửa sổ "Customize Individual Style" xuất hiện và tùy theo kiểu các đối tượng là đa giác, đường hay điểm trong khung Preview cũng như trong khung Style sẽ được thể hiện tương ứng với mỗi cấp được liệt kê trong khung Individual Value chúng ta có thể chọn dạng thức tùy ý bằng cách nhấn chuột vào mục Style. 
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         Kết quả sử dụng Create Thematic Map Individual 





                                           chú được cho tất cả các đối tượng thì để trống ô Maximun Labels. 
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         Kết quả dùng Create Thematic Map Ranges
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  Cửa số Customize Graduated Symbols
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    Kq của Create Thematic Map Graduated Symbols
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   Cửa sổ Customize Dot Density Settings
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  Kết quả của Create Thematic Map Dot Density 
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Khi chọn Bar Charts hay Pie Charts rồi chọn Next, trong cửa sổ Create Thematic Map – Step 2 of 3. Trước hết chúng ta sẽ khai báo tên lớp dữ liệu trong mục Table. Sau đó chúng ta sẽ chọn các cột dữ liệu sẽ được biểu hiện trong biểu đồ, có thể chọn cả một biểu thức hợp lệ để tính toán giá trị của các đối tượng trong 





                                              các cột tương ứng.  Trong cửa sổ Create Thematic Map – Step 3 of 3, MapInfo cho phép chúng ta chọn kích cỡ và màu sắc thể hiện các giá trị khi chúng ta click Styles trong khung Customize. 
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        Kết quả của Create Thematic Map Bar Charts
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      Kết quả của Create Thematic Map Pie Charts
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              Định lưới toạ độ địa lý với công cụ Grid Maker.
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         Tạo thước tỷ lệ với công cụ Draw ScaleBar.
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Thực hiện smooth & unsmooth
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 Thực hiện Convert Polylines & Convert Regions 
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Các node chung được tạo thành giữa 2 đối tượng khác nhau
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    Đổi tên 1 table
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                          Xoá 1 table
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Chúng ta có thể xuất toàn bộ dữ liệu hay chỉ một số các đối tượng của lớp dữ liệu, trong trường hợp này chúng ta phải chọn các đối tượng này trước khi vào Table -> Export. Chúng ta sẽ chọn lớp dữ liệu hay chỉ các đối tượng được chọn trong cửa sổ Export Table. Nhấn chuột vào Export  sẽ hiện tiếp cửa sổ Export Table to File. 
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     9                           10





  11                         12





  13                         14





  15                         16





  17                         18





  19                         20





21                        22





  23                         24





1. Select Button : Nút lệnh chọn dùng để chọn đối tượng trên cửa sổ bản đồ, bản ghi trên cửa sổ Browser hay các nội dung trên một số cửa sổ khác. Giữ phím <Shift> để chọn nhiều đối tượng hay nhiều bản ghi một lúc. Nếu nhiều đối tượng đang được chọn, giữ phím <Shift> và nhấp chuột lên đối tượng/bản ghi nào sẽ khử chọn nó.


2. Marquee Select Button : Chọn theo hình chữ nhật, là công cụ chọn bằng cách rê chuột trên vùng muốn chọn, khi rê chuột vùng được vẽ là hình chữ nhật và khi thả chuột những đối tượng có trọng tâm nằm trong hình chữ nhật sẽ được chọn.


3. Radius Select Button : Chọn theo hình tròn, khi rê chuột một hình tròn được tạo 





thành và khi nhả chuột ra tất cả những đối 





tượng có trọng tâm nằm trong vòng tròn đó sẽ được chọn.
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                                               nhấn chuột vào ô tương ứng của các thuộc tính này. Các chi tiết trong cửa sổ tab "Layer Control" sẽ được giải thích và trình bày trong phần thực chức năng hành.
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